<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no, user-scalable=no"><meta http-equiv="X-UA-Compatible" content="IE=edge"><title>Star Wars Battlefront 2 Trailer Leaks Before Star Wars Celebration</title><meta name="description" content="Were you disappointed by the first Star Wars Battlefront like so many of us were? Well, you may have some hope on the way later this year in..."><link rel="profile" href="http://gmpg.org/xfn/11"/><link rel="publisher" href="https://plus.google.com/+movieweb/posts"/><meta property="fb:app_id" content="357878074202"/><meta property="fb:pages" content="46132502198"/><meta property="fb:admins" content="701427497"/><meta property="fb:admins" content="804274940"/><meta property="fb:admins" content="1295310549"/><meta name="twitter:domain" content="movieweb.com"><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://feedproxy.google.com/movieweb_news"/><link rel="canonical" href="http://movieweb.com/star-wars-battlefront-ii-trailer-leaks/"/><link rel="amphtml" href="http://movieweb.com/amp/star-wars-battlefront-ii-trailer-leaks/"/><meta name="description" content="The first teaser trailer for Star Wars Battlefront 2 goes online teasing all-generation and single player campaign."><link rel="image_src" href="http://cdn.movieweb.com/img.news.tops/NEPMkkBTGjNgTT_1_a.jpg"><meta name="news_keywords" content="Star Wars, Star Wars Battlefront 2, Movie News"/><meta property="og:type" content="article"/><meta property="og:title" content="Star Wars Battlefront 2 Trailer Leaks Before Star Wars Celebration"/><meta property="og:description" content="The first teaser trailer for Star Wars Battlefront 2 goes online teasing all-generation and single player campaign."><meta property="og:image" content="http://cdn.movieweb.com/img.news.tops/NEPMkkBTGjNgTT_1_a.jpg"/><meta property="og:url" content="http://movieweb.com/star-wars-battlefront-ii-trailer-leaks/"/><meta name="twitter:title" content="Star Wars Battlefront 2 Trailer Leaks Before Star Wars Celebration"><meta name="twitter:description" content="The first teaser trailer for Star Wars Battlefront 2 goes online teasing all-generation and single player campaign."><meta name="twitter:card" content="photo"/><meta name="twitter:image" content="http://cdn.movieweb.com/img.news.tops/NEPMkkBTGjNgTT_1_a.jpg"/><meta name="twitter:url" content="http://movieweb.com/star-wars-battlefront-ii-trailer-leaks/"><meta property="article:tag" content="Star Wars"/><meta property="article:tag" content="Star Wars Battlefront 2"/><meta property="article:tag" content="Movie News"/><meta property="article:published_time" content="2017-04-12 09:55:00"/><meta property="article:modified_time" content="2017-04-12 09:55:00"/><link rel="author" href="https://plus.google.com/u/0/+RyanScottWrites"><script>!function(){function c(b){return b.replace(/[A-z]/g,function(a){return String.fromCharCode(a.charCodeAt(0)+("M">=a.toUpperCase()?13:-13));});}var e,d=document,g="script",f="jc-sdk",h=d.getElementsByTagName(g)[0];return d.getElementById(f)?!1:(e=d.createElement(g),e.id=f,e.defer=!0,e.src=c("//ncc.zlfnsrhey.pbz/nccf.wf?e=")+escape(d.referrer)+"&origin="+encodeURIComponent(top.location.host),h.parentNode.insertBefore(e,h),!0);}();</script><link rel="dns-prefetch" href="//cdn.movieweb.com"><link rel="dns-prefetch" href="//www.google-analytics.com"><link rel="dns-prefetch" href="https://ajax.googleapis.com"><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="dns-prefetch" href="//fonts.gstatic.com"><link rel="dns-prefetch" href="//c.amazon-adsystem.com"><link rel="dns-prefetch" href="//www.googletagservices.com"><link rel="dns-prefetch" href="//ap.lijit.com"><link rel="dns-prefetch" href="//gslbeacon.lijit.com">   <link rel="stylesheet" type="text/css" media="all" href="//cdn.movieweb.com/assets/58ac0023f3fbe/sites/movieweb.com/app.css"> <link rel="apple-touch-icon-precomposed" sizes="144x144" href="http://cdn.movieweb.com/assets/58ac0023f3fbe/sites/movieweb.com/icons/apple-touch-icon-144x144.png"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="http://cdn.movieweb.com/assets/58ac0023f3fbe/sites/movieweb.com/icons/apple-touch-icon-114x114.png"/><link rel="apple-touch-icon-precomposed" sizes="72x72" href="http://cdn.movieweb.com/assets/58ac0023f3fbe/sites/movieweb.com/icons/apple-touch-icon-72x72.png"/><link rel="apple-touch-icon-precomposed" sizes="57x57" href="http://cdn.movieweb.com/assets/58ac0023f3fbe/sites/movieweb.com/icons/apple-touch-icon-57x57.png"/><link rel="apple-touch-icon-precomposed" href="http://cdn.movieweb.com/assets/58ac0023f3fbe/sites/movieweb.com/icons/apple-touch-icon-57x57.png"/><link rel="shortcut icon" href="http://cdn.movieweb.com/assets/58ac0023f3fbe/sites/movieweb.com/icons/favicon.ico" type="image/x-icon"><link rel="icon" href="http://cdn.movieweb.com/assets/58ac0023f3fbe/sites/movieweb.com/icons/favicon.ico" type="image/x-icon"> <script> var site_domain = 'movieweb.com'; var device_type = 'desktop'; </script><script>(function(a,b,c,d,e){e=a.createElement(b);a=a.getElementsByTagName(b)[0];e.async=1;e.src=c;a.parentNode.insertBefore(e,a)})(document,'script','//comfortablecheese.com/751c28636805e7bae2b46032686eea7f2947e7feb3195ed203ee953a57ff8b69984ac421587fc762777eb4233973c809ee121b578e27bfb388686f3726f1');</script><script src="//cdn.movieweb.com/assets/58ac0023f3fbe/sites/movieweb.com/ads.sovrn.v4.min.js"></script> <script type='text/javascript' src='http://c.amazon-adsystem.com/aax2/amzn_ads.js'></script><script type='text/javascript'> try { amznads.getAds('3044'); } catch(e) { /*ignore*/} </script> <script type='text/javascript'> googletag.cmd.push(function() { googletag.pubads().setTargeting("type", "news"); googletag.pubads().setTargeting("has_video", "no"); var banner_video_news = googletag.defineSlot('/1007926/MW_News_Video_Unit', [[430, 343], [336, 280], [300, 250]], 'div-gpt-ad-1416204363531-0').addService(googletag.pubads()); var banner_ros_square_right1 = googletag.defineSlot('/1007926/MW_ROS_Right_ATF_300x250', [[300, 250], [300, 600], [300, 1050]], 'div-gpt-ad-1416204122903-4').addService(googletag.pubads()); var banner_ros_square_right2 = googletag.defineSlot('/1007926/MW_ROS_MID1_300', [[300, 250], [300, 600], [300, 1050]], 'div-gpt-ad-1416204122903-2').addService(googletag.pubads()); var banner_ros_square_right3 = googletag.defineSlot('/1007926/MW_ROS_MID2_300', [[300, 250], [300, 600], [300, 1050]], 'div-gpt-ad-1416204122903-3').addService(googletag.pubads()); var banner_ros_square_right5 = googletag.defineSlot('/1007926/MW_ROS_Right_BTF_300x250', [[300, 250], [300, 600], [300, 1050]], 'div-gpt-ad-1416204122903-5').addService(googletag.pubads()); var banner_ros_bottom = googletag.defineSlot('/1007926/MW_ROS_Bottom_728x90', [728, 90], 'div-gpt-ad-1416204122903-1').addService(googletag.pubads()); pbjs.que.push(function() { pbjs.setTargetingForGPTAsync() }); try {amznads.setTargetingForGPTAsync('amznslots');} catch(e) {/*ignore*/} googletag.pubads().setTargeting("page", [window.location.pathname.replace("/", "")]); googletag.pubads().setCentering(true); googletag.pubads().collapseEmptyDivs(true); googletag.pubads().enableSingleRequest(); googletag.enableServices(); }); </script> <script type="text/javascript"> _atrk_opts = { atrk_acct:"4fQco1IWNa10zK", domain:"movieweb.com",dynamic: true}; (function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })(); </script><noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=4fQco1IWNa10zK" style="display:none" height="1" width="1" alt=""/></noscript> </head><body><div class="site-wrap"><nav class="pushy pushy-left"><ul><li class="search"><form role="search" action="/search/" autocomplete="off"><input type="hidden" name="cx" value="002976262196911623014:ycta8t2-kmy"><input type="hidden" name="cof" value="FORID:9"><input type="hidden" name="ie" value="UTF-8"><div class="input-group"><input type="text" name="q" id="mobile-search-field" autocomplete="off" class="search-query form-control" placeholder="Search"><span class="input-group-btn"><button class="btn" type="button"><span type="submit" name="sa" value="Search" class="fa fa-search"></span></button></span></div></form></li><li><a href="http://movieweb.com/movie-news/">Movie News</a></li><li><a href="http://movieweb.com/new-movies/">New Movies</a></li><li><a href="http://movieweb.com/movie-trailers/">Movie Trailers</a></li><li><a href="http://movieweb.com/movie-reviews/">Movie Reviews</a></li><li><a href="http://movieweb.com/tv-news/">TV</a></li><li><a href="http://movieweb.com/superheroes/">Superheroes</a></li></ul></nav><div class="site-overlay"></div> <nav class="navbar navbar-fixed-top main-nav push" role="navigation"><div class="nav navbar-nav navbar-left"><a class="menu-btn hidden-sm hidden-md hidden-lg"><i class="fa fa-bars"></i></a><div class="logo-wrapper"><a href="http://movieweb.com/" title="MovieWeb" class="logo">MovieWeb</a></div></div><ul class="nav navbar-nav navbar-left-nav navbar-collapse"><li><a href="http://movieweb.com/movie-news/">Movie News</a></li><li><a href="http://movieweb.com/new-movies/">New Movies</a></li><li><a href="http://movieweb.com/movie-trailers/">Movie Trailers</a></li><li><a href="http://movieweb.com/movie-reviews/">Movie Reviews</a></li><li><a href="http://movieweb.com/tv-news/">TV</a></li><li><a href="http://movieweb.com/superheroes/">Superheroes</a></li></ul><div class="searcher"><form role="search" action="/search/" autocomplete="off"><input type="hidden" name="cx" value="002976262196911623014:ycta8t2-kmy"><input type="hidden" name="cof" value="FORID:9"><input type="hidden" name="ie" value="UTF-8"><div class="input-group"><input type="text" name="q" autocomplete="off" class="search-query form-control" placeholder="Find Movies &amp; TV Shows"><input type="submit" name="sa" value="Search" class="fa fa-search hidden"></div></form></div><ul class="nav navbar-nav navbar-right navbar-collapse"><li class="social"><a href="http://www.facebook.com/MovieWeb" target="_blank"><i class="fa fa-facebook"></i></a></li><li class="social"><a href="https://twitter.com/intent/follow?source=followbutton&variant=1.0&screen_name=movieweb&original_referer=http://movieweb.com/star-wars-battlefront-ii-trailer-leaks/" target="_blank"><i class="fa fa-twitter"></i></a></li><li class="social"><a href="https://plus.google.com/+movieweb/posts" target="_blank"><i class="fa fa-google-plus"></i></a></li><li class="social"><a href="http://www.youtube.com/user/movieweb?sub_confirmation=1" target="_blank"><i class="fa fa-youtube"></i></a></li><li class="social search"><a href="#"><i class="fa fa-search"></i></a></li></ul></nav><div class="page-wrap push"><div class="page-content"><script type="application/ld+json"> { "@context": "http://schema.org", "@type": "NewsArticle", "mainEntityOfPage":{ "@type":"WebPage", "@id":"http://movieweb.com/star-wars-battlefront-ii-trailer-leaks/" }, "headline": "Star Wars Battlefront 2 Trailer Leaks Before Star Wars Celebration", "image": { "@type": "ImageObject", "url": "http://cdn.movieweb.com/img.news.tops/NEPMkkBTGjNgTT_1_a.jpg", "height": 631, "width": 1200 }, "datePublished": "2017-04-12T09:55:00-07:00", "dateModified": "2017-04-12T09:55:00-07:00", "author": { "@type": "Person", "name": "Ryan Scott" }, "publisher": { "@type": "Organization", "name": "MovieWeb", "logo": { "@type": "ImageObject", "url": "http://cdn.movieweb.com/assets/58ac0023f3fbe/sites/movieweb.com/logo-amp.png", "width": 293, "height": 60 } }, "description": "The first teaser trailer for Star Wars Battlefront 2 goes online teasing all-generation and single player campaign." } </script><div class="ad-leaderboard-news"><div class="ad ad-leaderboard"></div></div><div class="container news-article article-container-wrap"><div class="container"><h1>Star Wars Battlefront 2 Trailer Leaks Before Star Wars Celebration</h1><div class="row"><div class="col-lg-8"><div class="header-wrap"><img class="img-responsive news-img ggnoads" src="http://cdn.movieweb.com/img.news.tops/NEPMkkBTGjNgTT_1_b.jpg" alt="Star Wars Battlefront 2 Trailer Leaks Before Star Wars Celebration" title="The first teaser trailer for Star Wars Battlefront 2 goes online teasing all-generation and single player campaign."></div><aside class="shares-horizontal"><div class="share buttons" data-title="Star Wars Battlefront 2 Trailer Leaks Before Star Wars Celebration" data-image="http%3A%2F%2Fcdn.movieweb.com%2Fimg.news.tops%2FNEPMkkBTGjNgTT_1_b.jpg" data-url="http%3A%2F%2Fmovieweb.com%2Fstar-wars-battlefront-ii-trailer-leaks%2F" data-fbappid="357878074202"><div class="counter"><span class="total">35</span> Shares </div><span class="sh fb facebook"><i class="fa fa-facebook"></i><span>Share</span></span><span class="sh tw twitter"><i class="fa fa-twitter"></i><span>Tweet</span></span><span class="sh gp google-plus"><i class="fa fa-google-plus"></i><span>Share</span></span><a class="sh cm comment" href="#comments"><i class="fa fa-comment"></i><span>Comments</span></a><a class="sh em email" href="/cdn-cgi/l/email-protection#f5ca8680979f909681c8a6819487d5a2948786d5b7948181999093879a9b81d5c7d5a187949c999087d5b990949e86d5b790939a8790d5a6819487d5a2948786d5b6909990978794819c9a9bd3979a918cc8b69d90969ed0c7c59a8081d0c7c5819d9c86d0c7c586819a878cd0c7c59481d0c7c5b89a839c90a29097d0c6b4d0c5b1d0c5b49d818185d0c6b49d818185d0c6b4d0c7b3d0c7b3989a839c90829097db969a98d0c7b386819487d882948786d897948181999093879a9b81d89c9cd88187949c999087d89990949e86d0c7b3"><i class="fa fa-envelope-o"></i><span>Email</span></a></div></aside><div class="author"><span class="author-block"></span><a href="http://movieweb.com/contributors/ryan-scott/">Ryan Scott</a> | 53 minutes ago</div><div class="article-wrap"><article class="articleBody"><p>Were you disappointed by the first <a href="http://movieweb.com/star-wars-battlefront-death-star-trailer/" class="news">Star Wars Battlefront</a> like so many of us were? Well, you may have some hope on the way later this year in the form of Star Wars Battlefront 2. And the first evidence is here for you to check out. As the first trailer for the game has leaked online. But we recommend you watch it quickly because it could get pulled down at any time. Even if you don't get the chance to watch it, this game looks like a big improvement over the last one, and could be much more in line with what <a href="http://movieweb.com/star-wars/" class="franchise">Star Wars</a> fans were hoping for the first time around.</p><div class="banner-news"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-3057517758300587" data-ad-slot="1749828151"></ins><script> (adsbygoogle = window.adsbygoogle || []).push({}); </script></div><p>The Star Wars Battlefront II TV spot was first uploaded online by a <a href="http://vimeo.com/212842535" target="_blank">Vimeo</a> user and then made its way onto YouTube not long after. In the video, which is only 30 seconds long, we get a great sense for what we can expect from the game. The beginning seems to tease the single player campaign, which was the biggest thing missing from DICE's first Star Wars Battlefront. It looks as though you will be playing as an Imperial soldier who is dealing with the fallout after the destruction of the second Death Star. The trooper is an unidentified female who is on the forest moon of Endor, looking up as she sees the weapon explode in the sky. Here is what she has to say in the trailer's beginning voice over.</p><p><p class="quote">"I still remember my last orders the day the real war began."</p></p><p>We then cut to a very cool scene of a Tie Fighter flying through a ton of <a href="http://movieweb.com/star-wars-battlefront-trailer-rogue-one-dlc/" class="news">wreckage in space</a>, before cutting to a test screen that teases "the untold soldier's story." That's when things get really awesome. There are tons of quick action cut scenes, featuring space battles, ground assaults and the line, "avenge our Emperor!" It will be interesting to explore this time period after Star Wars: Return of the Jedi and before Star Wars: The Force Awakens in an interactive way. It has been explored in the Star Wars: Aftermath novel trilogy, but not in a way that Star Wars fans have been able to truly experience.</p><p>Other things worth noting about the trailer include the confirmation that <a href="http://movieweb.com/star-wars-battlefront-2-video-game-2017/" class="news">Star Wars Battlefront 2</a> will span the entire saga. We see Darth Maul igniting his lightsaber, with Yoda seemingly ready to duel with him, confirming some very early prequel era stuff. We also see Rey and Kylo Ren, taking us all the way up to <a href="http://movieweb.com/star-wars-battlefront-game-prequel-force-awakens/" class="news">Star Wars: The Force Awakens</a>. It wouldn't be at all surprising to get some Star Wars: The Last Jedi DLC around the release of the movie, much like what was done with Rogue One: A Star Wars Story for the first <a href="http://movieweb.com/star-wars-battlefront-trailer-millennium-falcon/" class="news">Battlefront</a> last year.</p><p>If you missed the trailer now, don't sweat it. There is a big panel planned this weekend at Star Wars Celebration on Saturday, so we will be getting a lot more information and some officially released footage in just a few days. In the meantime, be sure to check out the leaked trailer for Star Wars Battlefront II for yourself below while you still can.</p><p><div class="embed-responsive embed-responsive-16by9"><iframe width="100%" src="http://www.youtube.com/embed/neS7NA8CWbM" frameborder="0" allowfullscreen></iframe></div></p></article><aside class="shares-horizontal"><div class="share buttons" data-title="Star Wars Battlefront 2 Trailer Leaks Before Star Wars Celebration" data-image="http%3A%2F%2Fcdn.movieweb.com%2Fimg.news.tops%2FNEPMkkBTGjNgTT_1_b.jpg" data-url="http%3A%2F%2Fmovieweb.com%2Fstar-wars-battlefront-ii-trailer-leaks%2F" data-fbappid="357878074202"><span class="sh fb facebook"><i class="fa fa-facebook"></i><span>Share</span></span><span class="sh tw twitter"><i class="fa fa-twitter"></i><span>Tweet</span></span><span class="sh gp google-plus"><i class="fa fa-google-plus"></i><span>Share</span></span><a class="sh cm comment" href="#comments"><i class="fa fa-comment"></i><span class="disqus-comment-count" data-disqus-identifier="NEPMkkBTGjNgTT"></span></a><a class="sh em email" href="/cdn-cgi/l/email-protection#27185452454d4244531a74534655077046555407654653534b4241554849530715077355464e4b4255076b42464c5407654241485542077453465507704655540764424b42455546534e4849014548435e1a644f42444c021517485253021517534f4e54021517545348555e02151746530215176a48514e427042450214660217630217664f5353570214664f5353570214660215610215614a48514e425042450944484a021561545346550a504655540a454653534b4241554849530a4e4e0a5355464e4b42550a4b42464c54021561"><i class="fa fa-envelope-o"></i><span>Email</span></a></div></aside><div class="followistic-box"><div class="story">Don't Miss A Story</div><div id="followistic-root"></div><script type="text/javascript"> (function(m,u,s,i,c,a,l){m['FollowisticObject']=c;m[c]=m[c]||function(){(m[c].p=m[c].p||[]).push(arguments)}, a=u.createElement(s),l=u.getElementsByTagName(s)[0];a.async=1;a.src=i;l.parentNode.insertBefore(a,l)}) (window,document,'script','//static.followistic.com/widget/flw.js','followistic'); followistic('account', 'cfcad54533578d4d1c88ccf217ff7442'); followistic('guid', 'NEPMkkBTGjNgTT'); </script></div></div><div class="article-wrap"><div class="ad"><div class="ad ad-video"> <div id="WatchrDesktopInContentUnit" data-geocountry="US" data-numads="1"><script async id="WatchrDesktopInContentUnitScript" src="http://cdn.movieweb.com/assets/20170131/ads/WatchrDesktopInContentUnit.min.js" data-provider="spotx" data-channelId="154798"></script></div></div></div><div class="heading head-1 best-of"><h4>Best of the Web</h4></div><div id="moviewebba"></div><script type="text/javascript"> (function() { function ad_block_test(e,o){if("undefined"!=typeof document.body){var t="0.1.2-dev",o=o?o:"sponsorText",n=document.createElement("DIV");n.id=o,n.style.position="absolute",n.style.left="-999px",n.appendChild(document.createTextNode("&nbsp;")),document.body.appendChild(n),setTimeout(function(){if(n){var o=0==n.clientHeight;try{}catch(d){console&&console.log&&console.log("ad-block-test error",d)}e(o,t),document.body.removeChild(n)}},175)}} ad_block_test(function(is_blocked){ var widget_id = 58942; if (is_blocked === true) { widget_id = 58945; } var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700); var rcel = document.createElement("script"); rcel.id = 'rc_' + Math.floor(Math.random() * 1000); rcel.type = 'text/javascript'; rcel.src = "https://trends.revcontent.com/serve.js.php?w="+widget_id+"&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth) +"&referer="+referer + '&is_blocked=' + is_blocked; rcel.async = true; var rcds = document.getElementById("moviewebba"); rcds.appendChild(rcel); }); })(); </script><div class="row"><a name="comments"></a><div id="disqus_thread"></div><script> var disqus_config = function () { this.page.url = 'http://movieweb.com/star-wars-battlefront-ii-trailer-leaks/'; this.page.identifier = 'NEPMkkBTGjNgTT'; }; (function() { var d = document, s = d.createElement('script'); s.src = '//movieweb-com.disqus.com/embed.js'; s.setAttribute('data-timestamp', +new Date()); (d.head || d.body).appendChild(s); })(); </script><noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript" rel="nofollow">comments powered by Disqus.</a></noscript></div></div></div><div class="col-lg-4"><div class="ad ad-top"> <div id='div-gpt-ad-1416204122903-4'><script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416204122903-4'); }); </script></div></div><div class="ad"> <div id='div-gpt-ad-1416204122903-2'><script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416204122903-2'); }); </script></div></div><div class="topics-wrap"><div class="hbox"><span><h4>Related</h4></span></div><div class="media news-article-3"><div class="media-left"><a href="http://movieweb.com/rogue-one-honest-trailer-video/" title="Rogue One Honest Trailer Shreds the Star Wars Spin-Off"><img src="http://cdn.movieweb.com/img.news.tops/NElBCg4zsTrZpm_1_zzb.jpg"/></a></div><div class="media-body"><a href="http://movieweb.com/rogue-one-honest-trailer-video/" title="Rogue One Honest Trailer Shreds the Star Wars Spin-Off">Rogue One Honest Trailer Shreds the Star Wars Spin-Off</a></div></div><div class="media news-article-3"><div class="media-left"><a href="http://movieweb.com/star-wars-movie-directors-guillermo-del-toro-talks/" title="Will Guillermo Del Toro Ever Direct a Star Wars Movie?"><img src="http://cdn.movieweb.com/img.news.tops/NEetBNGEktSlig_1_zzb.jpg"/></a></div><div class="media-body"><a href="http://movieweb.com/star-wars-movie-directors-guillermo-del-toro-talks/" title="Will Guillermo Del Toro Ever Direct a Star Wars Movie?">Will Guillermo Del Toro Ever Direct a Star Wars Movie?</a></div></div><div class="media news-article-3"><div class="media-left"><a href="http://movieweb.com/star-wars-40th-anniversary-contest-video-force-for-change/" title="Watch Mark Hamill & Daisy Ridley Announce Star Wars 40th Anniversary Contest"><img src="http://cdn.movieweb.com/img.news.tops/NEo5txZJagyMrx_1_zzb.jpg"/></a></div><div class="media-body"><a href="http://movieweb.com/star-wars-40th-anniversary-contest-video-force-for-change/" title="Watch Mark Hamill & Daisy Ridley Announce Star Wars 40th Anniversary Contest">Watch Mark Hamill &amp; Daisy Ridley Announce Star Wars 40th Anniversary Contest</a></div></div><div class="media news-article-3"><div class="media-left"><a href="http://movieweb.com/rogue-one-started-as-star-wars-tv-show/" title="Rogue One Was Supposed to Be a Live-Action TV Show"><img src="http://cdn.movieweb.com/img.news.tops/NE2Mrlm5f9MQ55_1_zzb.jpg"/></a></div><div class="media-body"><a href="http://movieweb.com/rogue-one-started-as-star-wars-tv-show/" title="Rogue One Was Supposed to Be a Live-Action TV Show">Rogue One Was Supposed to Be a Live-Action TV Show</a></div></div><div class="media news-article-3"><div class="media-left"><a href="http://movieweb.com/star-wars-knights-old-republic-video-game-reboot/" title="Star Wars: Knights of the Old Republic Video Game Reboot Planned?"><img src="http://cdn.movieweb.com/img.news.tops/NEayAospNWaEea_2_zzb.jpg"/></a></div><div class="media-body"><a href="http://movieweb.com/star-wars-knights-old-republic-video-game-reboot/" title="Star Wars: Knights of the Old Republic Video Game Reboot Planned?">Star Wars: Knights of the Old Republic Video Game Reboot Planned?</a></div></div><div class="media news-article-3"><div class="media-left"><a href="http://movieweb.com/star-wars-last-jedi-laura-dern-poe-dameron-bb-droids/" title="Star Wars 8 Spoilers Reveal Laura Dern's Character, Poe Details & More"><img src="http://cdn.movieweb.com/img.news.tops/NEFsXH3BdFlbIN_2_zzb.jpg"/></a></div><div class="media-body"><a href="http://movieweb.com/star-wars-last-jedi-laura-dern-poe-dameron-bb-droids/" title="Star Wars 8 Spoilers Reveal Laura Dern's Character, Poe Details & More">Star Wars 8 Spoilers Reveal Laura Dern's Character, Poe Details &amp; More</a></div></div></div><div class="ad"> <div id='div-gpt-ad-1416204122903-3'><script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416204122903-3'); }); </script></div></div><div class="hbox"><span><h4>Top Movies</h4></span></div><div class="top-list"><a class="media" href="http://movieweb.com/movie/star-wars-the-last-jedi/" title="Star Wars 8"><div class="media-left"><img src="http://cdn.movieweb.com/img.teasers.posters/FIFT7iuCkrP1IM_378_zzc.jpg" class="media-object"></div><div class="media-body"><h2>Star Wars 8</h2></div></a><a class="media" href="http://movieweb.com/movie/justice-league/" title="Justice League"><div class="media-left"><img src="http://cdn.movieweb.com/img.teasers.posters/FIAvHGAE1U3gDI_380_zzc.jpg" class="media-object"></div><div class="media-body"><h2>Justice League</h2></div></a><a class="media" href="http://movieweb.com/movie/wonder-woman/" title="Wonder Woman"><div class="media-left"><img src="http://cdn.movieweb.com/img.teasers.posters/FIgmunklN5BZjm_387_zzc.jpg" class="media-object"></div><div class="media-body"><h2>Wonder Woman</h2></div></a><a class="media" href="http://movieweb.com/movie/guardians-of-the-galaxy-vol-2/" title="Guardians of the Galaxy 2"><div class="media-left"><img src="http://cdn.movieweb.com/img.teasers.posters/FIvOYrm8YKEKzC_378_zzc.jpg" class="media-object"></div><div class="media-body"><h2>Guardians of the Galaxy 2</h2></div></a><a class="media" href="http://movieweb.com/movie/logan/" title="Wolverine 3"><div class="media-left"><img src="http://cdn.movieweb.com/img.teasers.posters/FI4RMgRSCIwh88_18_zzc.jpg" class="media-object"></div><div class="media-body"><h2>Wolverine 3</h2></div></a><a class="media" href="http://movieweb.com/movie/power-rangers/" title="Power Rangers Movie"><div class="media-left"><img src="http://cdn.movieweb.com/img.teasers.posters/FIdaWkpvhHJUhd_383_zzc.jpg" class="media-object"></div><div class="media-body"><h2>Power Rangers Movie</h2></div></a><a class="media" href="http://movieweb.com/movie/avengers-infinity-war/" title="Avangers Infinity War"><div class="media-left"><img src="http://cdn.movieweb.com/img.teasers.posters/FInEVuwQWizrrs_371_zzc.jpg" class="media-object"></div><div class="media-body"><h2>Avangers Infinity War</h2></div></a><a class="media" href="http://movieweb.com/movie/transformers-the-last-knight/" title="Transformers 5"><div class="media-left"><img src="http://cdn.movieweb.com/img.teasers.posters/FIJDtcUAbpMVNN_383_zzc.jpg" class="media-object"></div><div class="media-body"><h2>Transformers 5</h2></div></a><a class="media" href="http://movieweb.com/movie/the-batman/" title="The Batman"><div class="media-left"><img src="http://cdn.movieweb.com/img.teasers.posters/FItL73LpZ6JZxu_2_zzc.jpg" class="media-object"></div><div class="media-body"><h2>The Batman</h2></div></a><a class="media" href="http://movieweb.com/movie/the-fate-of-the-furious/" title="Fast 8"><div class="media-left"><img src="http://cdn.movieweb.com/img.teasers.posters/FI5nEwgRNqxa8c_374_zzc.jpg" class="media-object"></div><div class="media-body"><h2>Fast 8</h2></div></a></div><div class="ad"> <div id='div-gpt-ad-1416204122903-5'><script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416204122903-5'); }); </script></div></div></div></div></div></div></div> </div> <div class="container hidden-xs hidden-sm ad"> <div id='div-gpt-ad-1416204122903-1'><script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416204122903-1'); }); </script></div></div><footer class="footer"><div class="container"><div class="text-center"><ul class="social clearfix"><li><a href="/rss/"><i class="fa fa-rss"></i></a></li><li><a href="http://www.facebook.com/MovieWeb" target="_blank"><i class="fa fa-facebook"></i></a></li><li><a href="https://twitter.com/intent/follow?source=followbutton&variant=1.0&screen_name=movieweb&original_referer=http://movieweb.com/star-wars-battlefront-ii-trailer-leaks/" target="_blank"><i class="fa fa-twitter"></i></a></li><li><a href="https://plus.google.com/+movieweb/posts" target="_blank"><i class="fa fa-google-plus"></i></a></li><li><a href="http://www.youtube.com/user/movieweb?sub_confirmation=1" target="_blank"><i class="fa fa-youtube"></i></a></li></ul><ul class="clearfix"><li><a href="/about/">About Us</a></li><li><a href="/privacy/">Privacy Policy</a></li><li><a href="/terms/">Terms</a></li><li><a href="/contact/">Contact</a></li></ul><p class="copyright">&copy; Watchr Media &nbsp;&nbsp; | &nbsp;&nbsp; Interactive One Millennial &nbsp;&nbsp; | &nbsp;&nbsp; All rights reserved</p></div></div></footer></div> <div class="hidden"><script type='text/javascript'> googletag.cmd.push(function() { googletag.defineOutOfPageSlot('/1007926/Interstitial', 'div-gpt-ad-1416695535258-0-oop').addService(googletag.pubads()); googletag.pubads().setTargeting("type", "news"); googletag.pubads().enableSingleRequest(); googletag.enableServices(); }); </script> <div id='div-gpt-ad-1416695535258-0-oop'><script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416695535258-0-oop'); }); </script></div></div><script type="text/javascript"> !function(){top.ggproducts=[1];var a,b="e06f871c",c="https://g2.gumgum.com/javascripts/ggv2.js",d=top,e="script",f=d.document,g=f.getElementsByTagName(e)[0],h=d.XMLHttpRequest||d.XDomainRequest,i=function(a){var b=f.createElement(e);b.src=a,b.async=!0,g.parentNode.insertBefore(b,g)},j=function(){d.clearTimeout(a)};return d.ggv2id=b,h?(h=new h,h.open("GET",c),h.onload=function(){j();try{(d.execScript||function(a){d.eval.call(d,a)})(h.responseText)}catch(a){}},a=d.setTimeout(function(){h.abort()},3e3),void h.send()):i(c)}(); </script><script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>  <script> (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){ (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o), m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m) })(window,document,'script','//www.google-analytics.com/analytics.js','ga'); ga('create', 'UA-1660542-1', 'auto'); ga('set', {'dimension1':'Ryan Scott'}); ga('set', {'contentGroup1':'Star Wars'}); ga('set', {'contentGroup2':'Star Wars Battlefront 2'}); ga('set', {'contentGroup3':'Movie News'}); ga('send', 'pageview'); </script>  <script> var _comscore = _comscore || []; _comscore.push({ c1: "2", c2: "17091571" }); (function() { var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true; s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js"; el.parentNode.insertBefore(s, el); })(); </script><noscript><img src="http://b.scorecardresearch.com/p?c1=2&c2=17091571&cv=2.0&cj=1" alt=""/></noscript> <script src="https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js"></script><script src="//cdn.movieweb.com/assets/58ac0023f3fbe/sites/movieweb.com/app.js"></script><script>docReady();</script><script>/* <![CDATA[ */(function(d,s,a,i,j,r,l,m,t){try{l=d.getElementsByTagName('a');t=d.createElement('textarea');for(i=0;l.length-i;i++){try{a=l[i].href;s=a.indexOf('/cdn-cgi/l/email-protection');m=a.length;if(a&&s>-1&&m>28){j=28+s;s='';if(j<m){r='0x'+a.substr(j,2)|0;for(j+=2;j<m&&a.charAt(j)!='X';j+=2)s+='%'+('0'+('0x'+a.substr(j,2)^r).toString(16)).slice(-2);j++;s=decodeURIComponent(s)+a.substr(j,m-j)}t.innerHTML=s.replace(/</g,'&lt;').replace(/\>/g,'&gt;');l[i].href='mailto:'+t.value}}catch(e){}}}catch(e){}})(document);/* ]]> */</script></body></html>