<!DOCTYPE html>
<html lang="en-US">
<head>
<title>Deathstroke: Knights &amp; Dragons the Movie Trailer Brings R-Rated DC Animated Action</title>


<script>
 (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
 (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
 m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
 })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
 ga('create', 'UA-1660542-1', 'auto', {'useAmpClientId': true});
 ga('send', 'pageview', {
 'dimension1': 'movieweb.com',
 'dimension2': '|deathstroke-knights-and-dragons-the-movie-trailer|',
 'dimension3': 'ARxvhSqnnSwABy',
 'dimension4': '202006',
 'dimension5': '2020',
 'dimension6': 'Ryan Scott',
 'dimension7': 'AU3Kqrb7LwZS73',
 'dimension8': '484',
 'dimension9': 'Movie Trailers',
 'dimension10': 'Deathstroke' });
</script>



<script>
var site_domain = 'movieweb.com';
 var device_type = 'desktop';
 var news_type = 'article';
</script>

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="user-scalable=yes, initial-scale=1.0, width=device-width" />
<meta name="description" content="Warner Bros. has released a new trailer for Deathstroke: Knights &amp; Dragons, turning the CW Seed series into a full-length feature." /><meta property="fb:app_id" content="357878074202" />
<meta name="robots" content="max-image-preview:large" />
<link rel="canonical" href="https://movieweb.com/deathstroke-knights-and-dragons-the-movie-trailer/" />
<link rel="amphtml" href="https://movieweb.com/amp/deathstroke-knights-and-dragons-the-movie-trailer/" />
<meta property="og:title" content="&#8216;Deathstroke: Knights &amp; Dragons the Movie&#8217; Trailer Brings R-Rated DC Animated Action" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://cdn3.movieweb.com/i/article/rNjrS4Brmy7W0xAkRgNbeh2UUjXAWd/1200:100/Deathstroke-Knights-And-Dragons-The-Movie-Trailer.jpg" />
<meta property="og:url" content="https://movieweb.com/deathstroke-knights-and-dragons-the-movie-trailer/" />
<meta property="og:description" content="Warner Bros. has released a new trailer for &#8216;Deathstroke: Knights &amp; Dragons,&#8217; turning the CW Seed series into a full-length feature." />
<meta property="og:site_name" content="Movieweb" />
<meta property="article:published_time" content="2020-06-17T18:44:25-07:00" />
<meta property="article:section" content="Movie News" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@movieweb" />
<meta name="twitter:creator" content="@RyanScottWrites" />
<meta name="twitter:title" content="&#8216;Deathstroke: Knights &amp; Dragons the Movie&#8217; Trailer Brings R-Rated DC Animated Action" />
<meta name="twitter:description" content="Warner Bros. has released a new trailer for Deathstroke: Knights &amp; Dragons, turning the CW Seed series into a full-length feature." />
<meta name="twitter:image" content="https://cdn3.movieweb.com/i/article/rNjrS4Brmy7W0xAkRgNbeh2UUjXAWd/1200:100/Deathstroke-Knights-And-Dragons-The-Movie-Trailer.jpg" />
<meta name="twitter:image:alt" content="Deathstroke: Knights &amp; Dragons the Movie Trailer Brings R-Rated DC Animated Action" />
<meta name="twitter:url" content="https://movieweb.com/deathstroke-knights-and-dragons-the-movie-trailer/" />

<link rel="preconnect" href="https://cdn3.movieweb.com" as="image" />
<link rel="preconnect" href="https://www.google-analytics.com" as="script" />
<link rel="preconnect" href="https://securepubads.g.doubleclick.net" as="script" />
<link rel="preconnect" href="https://hb.vntsm.com" as="script" />
<link rel="preconnect" href="https://player.anyclip.com/" as="script" />
<link rel="preconnect" href="https://sb.scorecardresearch.com" as="script" />
<link rel="preconnect" href="https://certify-js.alexametrics.com" as="script" />
<link rel="preconnect" href="https://tag.durationmedia.net" as="script" />

<link rel="dns-prefetch" href="https://cdn3.movieweb.com" as="image" />
<link rel="dns-prefetch" href="https://www.google-analytics.com" as="script" />
<link rel="dns-prefetch" href="https://securepubads.g.doubleclick.net" as="script" />
<link rel="dns-prefetch" href="https://hb.vntsm.com" as="script" />
<link rel="dns-prefetch" href="https://player.anyclip.com/" as="script" />
<link rel="dns-prefetch" href="https://sb.scorecardresearch.com" as="script" />
<link rel="dns-prefetch" href="https://certify-js.alexametrics.com" as="script" />
<link rel="dns-prefetch" href="https://tag.durationmedia.net" as="script" />

<link rel="preconnect" href="https://cdn.rhombusads.com" as="script" />
<link rel="dns-prefetch" href="https://cdn.rhombusads.com" as="script" />
<link rel="preconnect" href="https://launcher.spot.im" as="script" />
<link rel="dns-prefetch" href="https://launcher.spot.im" as="script" />
<link rel="preconnect" href="https://s.ntv.io" as="script" />
<link rel="dns-prefetch" href="https://s.ntv.io" as="script" />

<link rel="preload" href="/assets/5ee48a15ae0f1/sites/sites-main/js/app2.min.js" as="script">
<link rel="preload" rel="stylesheet" href="/assets/5ee48a15ae0f1/sites/movieweb.com/css/article.min.css" as="style" />

<link rel="apple-touch-icon" sizes="144x144" href="/assets/5ee48a15ae0f1/sites/movieweb.com/icons/apple-touch-icon-144x144.png" />
<link rel="apple-touch-icon" sizes="114x114" href="/assets/5ee48a15ae0f1/sites/movieweb.com/icons/apple-touch-icon-114x114.png" />
<link rel="apple-touch-icon" sizes="72x72" href="/assets/5ee48a15ae0f1/sites/movieweb.com/icons/apple-touch-icon-72x72.png" />
<link rel="apple-touch-icon" sizes="57x57" href="/assets/5ee48a15ae0f1/sites/movieweb.com/icons/apple-touch-icon-57x57.png" />
<link rel="apple-touch-icon" href="/assets/5ee48a15ae0f1/sites/movieweb.com/icons/apple-touch-icon-57x57.png" />
<link rel="shortcut icon" href="/assets/5ee48a15ae0f1/sites/movieweb.com/icons/favicon.ico" type="image/x-icon" />
<link rel="icon" href="/assets/5ee48a15ae0f1/sites/movieweb.com/icons/favicon.ico" type="image/x-icon" />

<link rel="stylesheet" href="/assets/5ee48a15ae0f1/sites/movieweb.com/css/article.min.css" />



<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
 window.googletag = window.googletag || {cmd: []};
</script>

<script>
 googletag.cmd.push(function() {
 googletag.pubads().collapseEmptyDivs(true);
 banner_author = googletag.defineSlot('/1007926/Publishr/AU3Kqrb7LwZS73', [300, 250], 'div-gpt-author-AU3Kqrb7LwZS73').addService(googletag.pubads());
 banner_article_top = googletag.defineSlot('/1007926/ArticleTop', [[300,250],[320,50],[728, 90]], 'div-gpt-ad-ArticleTop').addService(googletag.pubads());
 banner_ros_square_right1 = googletag.defineSlot('/1007926/MW_ROS_Right_ATF_300x250', [[300, 250], [300, 600]], 'div-gpt-ad-1416204122903-4').addService(googletag.pubads());
 banner_ros_square_right2 = googletag.defineSlot('/1007926/MW_ROS_MID1_300', [[300, 250], [300, 600]], 'div-gpt-ad-1416204122903-2').addService(googletag.pubads());
 banner_ros_square_right3 = googletag.defineSlot('/1007926/MW_ROS_MID2_300', [[300, 250], [300, 600]], 'div-gpt-ad-1416204122903-3').addService(googletag.pubads());
 banner_page_bottom = googletag.defineSlot('/1007926/PageBottom', [[300,250], [320, 50], [728, 90], [970, 250]], 'div-gpt-ad-1416204122903-0').addService(googletag.pubads());
 banner_oop = googletag.defineOutOfPageSlot('/1007926/Interstitial', 'div-gpt-ad-1416695535258-0-oop').addService(googletag.pubads());
 googletag.pubads().disableInitialLoad();
 googletag.pubads().enableSingleRequest();
 googletag.enableServices();
 googletag.pubads().setTargeting("site", "movieweb.com");
 googletag.pubads().setTargeting("page", [window.location.pathname.replace("/", "")]);
 googletag.pubads().setTargeting("type", "news");
 });
</script>

<script>
 window.Watchr = window.Watchr || {tam: []};
 Watchr.tam_slots = [
 {
 slotID: 'div-gpt-ad-ArticleTop',
 sizes: [[300,250],[320,50],[728,90]]
 }, {
 slotID: 'div-gpt-ad-1416204122903-4',
 sizes: [[300,250],[300,600]]
 }, {
 slotID: 'div-gpt-ad-1416204122903-2',
 sizes: [[300,250],[300,600]]
 }, {
 slotID: 'div-gpt-ad-1416204122903-3',
 sizes: [[300,250],[300,600]]
 }, {
 slotID: 'div-gpt-ad-1416204122903-0',
 sizes: [[300,250],[320,50],[728,90],[970,250]]
 }, ];
 ! function(a9, a, p, s, t, A, g) {
 if (a[a9]) return;
 function q(c, r) {
 a[a9]._Q.push([c, r]);
 }
 a[a9] = {
 init: function() {
 q("i", arguments);
 },
 fetchBids: function() {
 q("f", arguments);
 },
 setDisplayBids: function() {},
 _Q: []
 };
 A = p.createElement(s);
 A.async = !0;
 A.src = t;
 g = p.getElementsByTagName(s)[0];
 g.parentNode.insertBefore(A, g);
 }("apstag", window, document, "script", "//c.amazon-adsystem.com/aax2/apstag.js");
 apstag.init({
 pubID: '3044', adServer: 'googletag'
 });
 document.addEventListener('WatchrDocReady', function() {
 Watchr.tam_slots.forEach((item, i, arr) => {
 var clean_sizes = [];
 Watchr.ad_container_size = document.getElementById(item.slotID).parentElement.offsetWidth;
 if (Watchr.ad_container_size > 0) {
 if (item.slotID === 'div-gpt-ad-ArticleTop' && Watchr.ad_container_size >= 728) {
 item.sizes.forEach((size) => {
 if (size[1] <= 90) {
 clean_sizes.push(size);
 }
 });
 } else {
 item.sizes.forEach((size) => {
 if (size[0] <= Watchr.ad_container_size) {
 clean_sizes.push(size);
 }
 });
 }
 if (clean_sizes.length > 0) {
 arr[i].sizes = clean_sizes;
 } else {
 arr.splice(i, 1);
 }
 }
 });
 apstag.fetchBids({slots: Watchr.tam_slots}, function(bids) {
 if (typeof(window.console) !== 'undefined') {
 console.log('Got Bids: ' + bids.length);
 console.log(bids);
 }
 googletag.cmd.push(function() {
 apstag.setDisplayBids();
 googletag.pubads().refresh();
 });
 });
 });
</script>



<script>
 window.__is_non_eu = function() {};
 (function(){document.write('<div id="vmv3-ad-manager" style="display:none"></div>');document.getElementById("vmv3-ad-manager").innerHTML='<iframe id="vmv3-frm" src="javascript:\'<html><body></body></html>\'" width="0" height="0" data-mode="scan" data-site-id="58e226bf46e0fb0001e14e8b"></iframe>';var a=document.getElementById("vmv3-frm");a=a.contentWindow?a.contentWindow:a.contentDocument;a.document.open();a.document.write('<script src="https://hb.vntsm.com/v3/live/ad-manager.min.js" async>'+'</scr'+'ipt>');a.document.close()})();
</script>


<script>var rhombusSiteId = 1097075;</script>
<script type="text/javascript" id="rhscript" src="https://cdn.rhombusads.com/js/rh.min.js"></script>


<script type="application/ld+json">
{
 "@context": "http://schema.org",
 "@type": "NewsArticle",
 "mainEntityOfPage": {
 "@type": "WebPage",
 "@id": "https://movieweb.com/deathstroke-knights-and-dragons-the-movie-trailer/"
 },
 "headline": "Deathstroke: Knights &amp; Dragons the Movie Trailer Brings R-Rated DC Animated Action",
 "image":{
 "@type": "ImageObject",
 "url": "https://cdn3.movieweb.com/i/article/rNjrS4Brmy7W0xAkRgNbeh2UUjXAWd/1200:100/Deathstroke-Knights-And-Dragons-The-Movie-Trailer.jpg",
 "width": 1200,
 "height": 632 },
 "datePublished": "2020-06-17T18:44:25-07:00",
 "dateModified": "2020-06-17T18:45:28-07:00",
 "author": {
 "@type": "Person",
 "@id": "https://movieweb.com/contributors/ryan-scott/",
 "name": "Ryan Scott",
 "sameAs":[
 "https://movieweb.com/contributors/ryan-scott/"
 ]
 }, "publisher": {
 "@type": "Organization",
 "@id": "https://movieweb.com/",
 "name": "Movieweb",
 "sameAs": [
 "https://www.facebook.com/movieweb/",
 "https://twitter.com/intent/follow?source=followbutton&amp;variant=1.0&amp;screen_name=movieweb",
 "https://www.youtube.com/movieweb?sub_confirmation=1",
 "https://www.instagram.com/movieweb/"
 ],
 "logo": {
 "@type": "ImageObject",
 "url": "https://movieweb.com/assets/5ee48a15ae0f1/sites/movieweb.com/logo-amp.png",
 "width": 293,
 "height": 60
 }
 },
 "articleSection":["movie-trailers","deathstroke"],
 "description": "Warner Bros. has released a new trailer for Deathstroke: Knights &amp; Dragons, turning the CW Seed series into a full-length feature."
}
</script>
<script type="application/ld+json">
 {
 "@context": "https://schema.org",
 "@type": "BreadcrumbList",
 "itemListElement": [
 {
 "@type": "ListItem",
 "position": 1,
 "name": "Home",
 "item": "https://movieweb.com/"
 },
 {
 "@type": "ListItem",
 "position":2,
 "name": "Movie Trailers",
 "item": "https://movieweb.com/movie-trailers/"
 }, {
 "@type": "ListItem",
 "position":3,
 "name": "Deathstroke: Knights &amp; Dragons the Movie Trailer Brings R-Rated DC Animated Action",
 "item": "https://movieweb.com/deathstroke-knights-and-dragons-the-movie-trailer/"
 }
 ]
 }
</script>
</head>
<body>
<header class="site-header">
<div class="inner">
<div class="site-title">
<a href="https://movieweb.com/" class="site-logo">Movieweb</a>
</div>
<button class="site-nav-button">
<span>Menu</span>
</button>
<nav class="site-nav">
<div class="site-nav-social">
<ul class="site-nav-social-items">
<li class="site-nav-social-facebook">
<a href="https://www.facebook.com/movieweb/" target="_blank"><span>Facebook</span></a>
</li>
<li class="site-nav-social-twitter">
<a href="https://twitter.com/intent/follow?source=followbutton&variant=1.0&screen_name=movieweb&original_referer=https://movieweb.com/deathstroke-knights-and-dragons-the-movie-trailer/" target="_blank"><span>Twitter</span></a>
</li>
<li class="site-nav-social-instagram">
<a href="https://www.instagram.com/movieweb/" target="_blank"><span>Instagram</span></a>
</li>
<li class="site-nav-social-youtube">
<a href="https://www.youtube.com/movieweb?sub_confirmation=1" target="_blank"><span>YouTube</span></a>
</li>
<li class="site-nav-social-feed">
<a href="https://movieweb.com/rss/"><span>Feed</span></a>
</li>
</ul>
</div>
<div class="site-nav-content">
<ul class="site-nav-content-items" itemscope itemtype="http://www.schema.org/SiteNavigationElement">
<li itemprop="name"><a href="/movie-news/" itemprop="url">Movie News</a></li>
<li itemprop="name"><a href="/movies/2020/" itemprop="url">2020 Movies</a></li>
<li itemprop="name"><a href="/movie-trailers/" itemprop="url">Movie Trailers</a></li>
<li itemprop="name"><a href="/movie-reviews/" itemprop="url">Movie Reviews</a></li>
<li itemprop="name"><a href="/tv-news/" itemprop="url">TV News</a></li>
</ul>
</div>
</nav>
<div class="current-article-header">
<div class="current-article-overview">

<p class="current-article-title">&#8216;Deathstroke: Knights &amp; Dragons the Movie&#8217; Trailer Brings R-Rated DC Animated Action</p>
</div>
<ul class="current-article-actions">
<li>
<button class="current-article-button current-article-button-facebook facebook">
<span class="current-article-button-facebook-label-share">Share</span>
</button>
</li>
<li>
<a href="#spotim_wrapper" class="current-article-button current-article-button-comments">
<span class="current-article-button-comments-label-comments">Comments</span>
<span class="current-article-button-comments-label-count"></span>
</a>
</li>
</ul>
</div>
<div class="site-search">
<button type="button" class="site-search-open-button" data-toggle="site-search-form">
<span>Search</span>
</button>
<form id="site-search-form" class="site-search-form" data-toggle-focus="site-search-input" action="/search/">
<input type="hidden" name="cx" value="002976262196911623014:ycta8t2-kmy">
<input type="hidden" name="cof" value="FORID:9">
<input type="hidden" name="ie" value="UTF-8">
<button type="button" class="site-search-close-button" data-close="site-search-form">
<span>Close</span>
</button>
<input id="site-search-input" type="search" class="site-search-input" name="q" placeholder="Find Movies &amp; TV Shows" autocomplete="off">
<button type="submit" class="site-search-submit-button">
<span>Search</span>
</button>
</form>
</div>
</div>
</header>
<main class="main page-articles">
<div class="inner">
<div class="article-list">
<article class="article type-article">

<header class="article-header" data-newsid="ARxvhSqnnSwABy" data-loadmore="true" data-newscategory="Movie Trailers" data-title="Deathstroke: Knights &amp; Dragons the Movie Trailer Brings R-Rated DC Animated Action" data-image="https%3A%2F%2Fcdn3.movieweb.com%2Fi%2Farticle%2FrNjrS4Brmy7W0xAkRgNbeh2UUjXAWd%2F1200%3A100%2FDeathstroke-Knights-And-Dragons-The-Movie-Trailer.jpg" data-url="https%3A%2F%2Fmovieweb.com%2Fdeathstroke-knights-and-dragons-the-movie-trailer%2F" data-shares="98" data-fbappid="357878074202">
<h1 class="article-header-title">Deathstroke: Knights &amp; Dragons the Movie Trailer Brings R-Rated DC Animated Action</h1>
<p class="article-header-excerpt">Warner Bros. has released a new trailer for Deathstroke: Knights &amp; Dragons, turning the CW Seed series into a full-length feature.</p>
<div class="article-header-info">
<ul class="article-header-credits">
<li class="article-header-author"><a href="/contributors/ryan-scott/">Ryan Scott</a></li>
<li class="article-header-author-social">
<i class="author-twitter" data-twitter="RyanScottWrites"></i></li>
<li class="article-header-date">— <time datetime="2020-06-17T18:44:25-07:00">June 17, 2020</time></li>
<li class="article-header-category">in <a href="/movie-trailers/">Movie Trailers</a></li>
</ul>
</div>
<figure class="article-header-figure">
<picture>
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source media="(min-width: 1024px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 1024px) and (min-resolution: 120dpi)" sizes="798px" srcset="https://cdn3.movieweb.com/i/article/rNjrS4Brmy7W0xAkRgNbeh2UUjXAWd/798:75/Deathstroke-Knights-And-Dragons-The-Movie-Trailer.jpg 1197w" />
<source media="(min-width: 1024px)" sizes="798px" srcset="https://cdn3.movieweb.com/i/article/rNjrS4Brmy7W0xAkRgNbeh2UUjXAWd/798:75/Deathstroke-Knights-And-Dragons-The-Movie-Trailer.jpg 798w" />
<source media="(min-width: 768px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 768px) and (min-resolution: 120dpi)" sizes="963px" srcset="https://cdn3.movieweb.com/i/article/rNjrS4Brmy7W0xAkRgNbeh2UUjXAWd/963:75/Deathstroke-Knights-And-Dragons-The-Movie-Trailer.jpg 1444w" />
<source media="(min-width: 768px)" sizes="963px" srcset="https://cdn3.movieweb.com/i/article/rNjrS4Brmy7W0xAkRgNbeh2UUjXAWd/963:75/Deathstroke-Knights-And-Dragons-The-Movie-Trailer.jpg 963w" />
<source media="(min-width: 481px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 481px) and (min-resolution: 120dpi)" sizes="767px" srcset="https://cdn3.movieweb.com/i/article/rNjrS4Brmy7W0xAkRgNbeh2UUjXAWd/767:75/Deathstroke-Knights-And-Dragons-The-Movie-Trailer.jpg 1150w" />
<source media="(min-width: 481px)" sizes="767px" srcset="https://cdn3.movieweb.com/i/article/rNjrS4Brmy7W0xAkRgNbeh2UUjXAWd/767:75/Deathstroke-Knights-And-Dragons-The-Movie-Trailer.jpg 767w" />
<source media="(min-width: 0px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 0px) and (min-resolution: 120dpi)" sizes="480px" srcset="https://cdn3.movieweb.com/i/article/rNjrS4Brmy7W0xAkRgNbeh2UUjXAWd/480:75/Deathstroke-Knights-And-Dragons-The-Movie-Trailer.jpg 720w" />
<source media="(min-width: 0px)" sizes="480px" srcset="https://cdn3.movieweb.com/i/article/rNjrS4Brmy7W0xAkRgNbeh2UUjXAWd/480:75/Deathstroke-Knights-And-Dragons-The-Movie-Trailer.jpg 480w" />
<!--[if IE 9]></video><![endif]-->
<img class="lazyload" alt="Deathstroke: Knights & Dragons the Movie Trailer Brings R-Rated DC Animated Action" />
</picture>
</figure>
</header>
<div class="ad-leaderboard-news ad-leaderboard-wrap">

<div id='div-gpt-ad-ArticleTop'>
<script>
 googletag.cmd.push(function() { googletag.display('div-gpt-ad-ArticleTop'); });
</script>
</div>
</div>
<div class="article-body-wrap">
<ul class="article-header-social">
<li class="article-header-social-shares">
<span class="article-header-social-shares-count">98</span>
<span class="article-header-social-shares-label">shares</span>
</li>
<li class="article-header-social-item article-header-facebook facebook">
<a href="#"><span>Facebook</span></a>
</li>
<li class="article-header-social-item article-header-twitter twitter">
<a href="#"><span>Twitter</span></a>
</li>
<li class="article-header-social-item article-header-reddit reddit">
<a href="#"><span>Reddit</span></a>
</li>
<li class="article-header-social-item article-header-email email">
<a href="#"><span>Email</span></a>
</li>
<li class="article-header-social-item article-header-comment comment">
<a href="#spotim_wrapper"><span>Comment</span></a>
</li>
</ul>
<div class="article-body">
<p>A new trailer for <a href="https://movieweb.com/movie/deathstroke-knights-dragons-the-movie/">Deathstroke: Knights &amp; Dragons</a> has arrived online. This latest DC animated feature is interesting as it started life as a short-form series on CW Seed. But more than 50 minutes of footage has been added, given fans an entire movie to enjoy. The trailer showcases the R-rated adventure to come, with Slade Wilson getting his hands very dirty on a quest to save his family.</p>
<figure class="embed-youtube"><iframe class="lazyload" data-src="//www.youtube.com/embed/K2dMzlOIVxg" width="100%" allowfullscreen=""></iframe></figure>
<p>The trailer opens up with <a href="https://movieweb.com/suicide-squad-movie-deathstroke-scott-eastwood/">Slade Wilson's transformation</a> into the assassin known as Deathstroke. Things get action-heavy in a hurry before we find the mercenary put in a tough spot. A large body count is racked up, plenty of bullets fly and there is quite a bit of emotion layered in to break up the violence. Even though this came to life in a non-traditional way, converting a series into a full-length movie, it looks to be in line with what we have come to expect from the animated DC affairs, which are often quite good, save for the occasional exception.</p>
<span class="related">RELATED: <a href="/deathstroke-movie-development-gareth-evans-not-involved/">Deathstroke Movie No Longer Happening with The Raid Director</a></span>
<div class="ad-article-wrapper">
<div class="ad-article">

<div id='div-gpt-author-AU3Kqrb7LwZS73'>
<script>
 googletag.cmd.push(function() {
 googletag.display('div-gpt-author-AU3Kqrb7LwZS73');
 });
</script>
</div>
</div>
</div>
<p>The cast is led by Michael Chiklis (<em>The Shield</em>, <em>American Horror Story</em>) as Slade Wilson/<a href="https://movieweb.com/deathstroke-movie-story-gareth-evans/">Deathstroke</a>. Also starring are Sasha Alexander (<em>Rizzoli &amp; Isles</em>, <em>NCIS</em>) as Addie Kane Wilson, Chris Jai Alex (<em>ThunderCats Roar</em>, <em>Extraction</em>) as The Jackal, Faye Mata (<em>League of Legends</em>) as Jade/H.I.V.E Queen, Griffin Puatu (<em>Beastars</em>) as Joseph/Jericho, Imari Williams (<em>Transformers: Rescue Bots</em>, <em>LEGO DC: Shazam! Magic and Monsters</em>) as President Nichols, Asher Bishop (<em>The Angry Birds Movie 2</em>) as Young Joseph, Colin Salmon (<em>Krypton</em>, <em>Arrow</em>) as William Wintergreen, Delbert Hunt (<em>Bad Henry</em>) as Bronze Tiger, Panta Mosleh (<em>Always Be My Maybe</em>, <em>Pass The Salt</em>) as Lady Shiva and Noshir Dalal (<em>Red Dead Redemption II</em>) as Kapoor. Castulo Guerra (<em>The Usual Suspects</em>, <em>Jane The Virgin</em>) as General Suarez and Minae Noji (<em>General Hospital</em>) as Secretary of State round out the ensemble.</p>
<p>In <em>Deathstroke: Knights &amp; Dragons</em>, <a href="https://movieweb.com/deathstroke-joe-manganiello-justice-league-photo/">mercenary and master assassin</a> Slade Wilson leads two lives. One as the relentless killer known as Deathstroke, and the other as a dedicated family man. A vicious terror group known as H.I.V.E. forces his worlds to collide, which pushes the killer in Slade to fight for the lives of his loved ones. With his soul torn apart and his young son taken prisoner, Deathstroke will have to atone for the sins of his past to fuel the battles of his future.</p>
<span id="nativo1"></span>
<p>Sung Jin Ahn (<em>Niko and the Sword of Light</em>) is in the director's chair, working from a screenplay by J.M. DeMatteis (<em>Superman: Red Son</em>, <em>Batman: Bad Blood</em>). Sam Register, Greg Berlanti and Sarah Schechter are on board as executive producers. Warner Bros. has not revealed a firm release date yet, but <em>Deathstroke: Knights &amp; Dragons</em> is set to arrive on digital and Blu-ray/DVD later this summer. Be sure to check out the new trailer for yourself. This news was first reported by <a href="http://za.ign.com/deathstroke-vol-1/144724/video/deathstroke-knights-dragons-the-movie-exclusive-trailer" target="_blank">IGN</a>.</p>
<p class="article-tags">
Topics: <a href="/tag/deathstroke/">Deathstroke</a></p>
<div class="author-info">
<img src="https://cdn3.movieweb.com/i/author/hq9sotOr3jFhIFY32kXpJOdvB1moxF/60:70/Ryan-Scott.jpg" class="author-img" alt="Ryan Scott at Movieweb"><div class="author-media">
<span class="author-name" data-profile="/contributors/ryan-scott/">Ryan Scott</span>
<div class="author-social">
<span class="author-twitter" data-twitter="RyanScottWrites"></span></div>
</div>
<aside class="author-bio">Writer of various things on the internet (mostly about movies) since 2013. Major lover of popcorn flicks. Avid appreciator of James Bond, Marvel and Star Wars. Has a tremendously fat cat named Buster and still buys CDs. I’ve got my reasons.</aside>
</div>
</div>
</div>
</article>

<footer class="article-footer">
<section class="article-add-comment" id="comments">
<h2 class="article-add-comment-title">Deathstroke: Knights &amp; Dragons the Movie Trailer Brings R-Rated DC Animated Action</h2>
<button type="button" class="article-add-comment-close-button" data-close="comments">
<span>Close</span>
</button>
<div id="disqus_thread" class="article-add-comment-disqus"></div>
</section>
<div class="article-footer-ad">

<script src="https://player.anyclip.com/anyclip-widget/lre-widget/prod/v1/src/lre.js" async pubname="moviewebcom" widgetname="001w000001jTTSl_1225"></script>
</div>
<section class="article-more">
<h3 class="article-more-subheading">More Movie News</h3>
<div class="article-more-links">
<article>
<a href="/deathstroke-movie-joe-manganiello-what-he-wants/">
<picture>
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source media="(min-width: 1024px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 1024px) and (min-resolution: 120dpi)" sizes="386px" data-srcset="https://cdn3.movieweb.com/i/article/nRJz21H6JeA5KxFPotrBSvpKCFWal8/386:50/Deathstroke-Movie-Joe-Manganiello-What-He-Wants.jpg 579w" />
<source media="(min-width: 1024px)" sizes="386px" data-srcset="https://cdn3.movieweb.com/i/article/nRJz21H6JeA5KxFPotrBSvpKCFWal8/386:50/Deathstroke-Movie-Joe-Manganiello-What-He-Wants.jpg 386w" />
<source media="(min-width: 768px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 768px) and (min-resolution: 120dpi)" sizes="471px" data-srcset="https://cdn3.movieweb.com/i/article/nRJz21H6JeA5KxFPotrBSvpKCFWal8/471:50/Deathstroke-Movie-Joe-Manganiello-What-He-Wants.jpg 706w" />
<source media="(min-width: 768px)" sizes="471px" data-srcset="https://cdn3.movieweb.com/i/article/nRJz21H6JeA5KxFPotrBSvpKCFWal8/471:50/Deathstroke-Movie-Joe-Manganiello-What-He-Wants.jpg 471w" />
<source media="(min-width: 481px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 481px) and (min-resolution: 120dpi)" sizes="737px" data-srcset="https://cdn3.movieweb.com/i/article/nRJz21H6JeA5KxFPotrBSvpKCFWal8/737:50/Deathstroke-Movie-Joe-Manganiello-What-He-Wants.jpg 1105w" />
<source media="(min-width: 481px)" sizes="737px" data-srcset="https://cdn3.movieweb.com/i/article/nRJz21H6JeA5KxFPotrBSvpKCFWal8/737:50/Deathstroke-Movie-Joe-Manganiello-What-He-Wants.jpg 737w" />
<source media="(min-width: 0px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 0px) and (min-resolution: 120dpi)" sizes="450px" data-srcset="https://cdn3.movieweb.com/i/article/nRJz21H6JeA5KxFPotrBSvpKCFWal8/450:50/Deathstroke-Movie-Joe-Manganiello-What-He-Wants.jpg 675w" />
<source media="(min-width: 0px)" sizes="450px" data-srcset="https://cdn3.movieweb.com/i/article/nRJz21H6JeA5KxFPotrBSvpKCFWal8/450:50/Deathstroke-Movie-Joe-Manganiello-What-He-Wants.jpg 450w" />
<!--[if IE 9]></video><![endif]-->
<img class="lazyload" alt="What Joe Manganiello Wants His Deathstroke Movie to Be" />
</picture>
</a>
<h3 class="article-more-links-title" title="What Joe Manganiello Wants His Deathstroke Movie to Be"><a href="/deathstroke-movie-joe-manganiello-what-he-wants/">What Joe Manganiello Wants His Deathstroke Movie to Be</a></h3>
</article>
<article>
<a href="/deathstroke-movie-update-joe-manganiello/">
<picture>
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source media="(min-width: 1024px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 1024px) and (min-resolution: 120dpi)" sizes="386px" data-srcset="https://cdn3.movieweb.com/i/article/4qU22kHPdc47YH9ZKpRXMhCfBvpb2P/386:50/Deathstroke-Movie-Update-Joe-Manganiello.jpg 579w" />
<source media="(min-width: 1024px)" sizes="386px" data-srcset="https://cdn3.movieweb.com/i/article/4qU22kHPdc47YH9ZKpRXMhCfBvpb2P/386:50/Deathstroke-Movie-Update-Joe-Manganiello.jpg 386w" />
<source media="(min-width: 768px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 768px) and (min-resolution: 120dpi)" sizes="471px" data-srcset="https://cdn3.movieweb.com/i/article/4qU22kHPdc47YH9ZKpRXMhCfBvpb2P/471:50/Deathstroke-Movie-Update-Joe-Manganiello.jpg 706w" />
<source media="(min-width: 768px)" sizes="471px" data-srcset="https://cdn3.movieweb.com/i/article/4qU22kHPdc47YH9ZKpRXMhCfBvpb2P/471:50/Deathstroke-Movie-Update-Joe-Manganiello.jpg 471w" />
<source media="(min-width: 481px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 481px) and (min-resolution: 120dpi)" sizes="737px" data-srcset="https://cdn3.movieweb.com/i/article/4qU22kHPdc47YH9ZKpRXMhCfBvpb2P/737:50/Deathstroke-Movie-Update-Joe-Manganiello.jpg 1105w" />
<source media="(min-width: 481px)" sizes="737px" data-srcset="https://cdn3.movieweb.com/i/article/4qU22kHPdc47YH9ZKpRXMhCfBvpb2P/737:50/Deathstroke-Movie-Update-Joe-Manganiello.jpg 737w" />
<source media="(min-width: 0px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 0px) and (min-resolution: 120dpi)" sizes="450px" data-srcset="https://cdn3.movieweb.com/i/article/4qU22kHPdc47YH9ZKpRXMhCfBvpb2P/450:50/Deathstroke-Movie-Update-Joe-Manganiello.jpg 675w" />
<source media="(min-width: 0px)" sizes="450px" data-srcset="https://cdn3.movieweb.com/i/article/4qU22kHPdc47YH9ZKpRXMhCfBvpb2P/450:50/Deathstroke-Movie-Update-Joe-Manganiello.jpg 450w" />
<!--[if IE 9]></video><![endif]-->
<img class="lazyload" alt="Deathstroke Movie Is Still Alive at DC According to Joe Manganiello" />
</picture>
</a>
<h3 class="article-more-links-title" title="Deathstroke Movie Is Still Alive at DC According to Joe Manganiello"><a href="/deathstroke-movie-update-joe-manganiello/">Deathstroke Movie Is Still Alive at DC According to Joe Manganiello</a></h3>
</article>
<article>
<a href="/justice-league-deathstroke-praise-joe-manganiello/">
<picture>
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source media="(min-width: 1024px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 1024px) and (min-resolution: 120dpi)" sizes="386px" data-srcset="https://cdn3.movieweb.com/i/article/FhwOABVtKa2UkLeQoPnddGXPiAPkZ8/386:50/Justice-League-Deathstroke-Praise-Joe-Manganiello.jpg 579w" />
<source media="(min-width: 1024px)" sizes="386px" data-srcset="https://cdn3.movieweb.com/i/article/FhwOABVtKa2UkLeQoPnddGXPiAPkZ8/386:50/Justice-League-Deathstroke-Praise-Joe-Manganiello.jpg 386w" />
<source media="(min-width: 768px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 768px) and (min-resolution: 120dpi)" sizes="471px" data-srcset="https://cdn3.movieweb.com/i/article/FhwOABVtKa2UkLeQoPnddGXPiAPkZ8/471:50/Justice-League-Deathstroke-Praise-Joe-Manganiello.jpg 706w" />
<source media="(min-width: 768px)" sizes="471px" data-srcset="https://cdn3.movieweb.com/i/article/FhwOABVtKa2UkLeQoPnddGXPiAPkZ8/471:50/Justice-League-Deathstroke-Praise-Joe-Manganiello.jpg 471w" />
<source media="(min-width: 481px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 481px) and (min-resolution: 120dpi)" sizes="737px" data-srcset="https://cdn3.movieweb.com/i/article/FhwOABVtKa2UkLeQoPnddGXPiAPkZ8/737:50/Justice-League-Deathstroke-Praise-Joe-Manganiello.jpg 1105w" />
<source media="(min-width: 481px)" sizes="737px" data-srcset="https://cdn3.movieweb.com/i/article/FhwOABVtKa2UkLeQoPnddGXPiAPkZ8/737:50/Justice-League-Deathstroke-Praise-Joe-Manganiello.jpg 737w" />
<source media="(min-width: 0px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 0px) and (min-resolution: 120dpi)" sizes="450px" data-srcset="https://cdn3.movieweb.com/i/article/FhwOABVtKa2UkLeQoPnddGXPiAPkZ8/450:50/Justice-League-Deathstroke-Praise-Joe-Manganiello.jpg 675w" />
<source media="(min-width: 0px)" sizes="450px" data-srcset="https://cdn3.movieweb.com/i/article/FhwOABVtKa2UkLeQoPnddGXPiAPkZ8/450:50/Justice-League-Deathstroke-Praise-Joe-Manganiello.jpg 450w" />
<!--[if IE 9]></video><![endif]-->
<img class="lazyload" alt="Deathstroke Co-Creator Praises Joe Manganiello for Justice League" />
</picture>
</a>
<h3 class="article-more-links-title" title="Deathstroke Co-Creator Praises Joe Manganiello for Justice League"><a href="/justice-league-deathstroke-praise-joe-manganiello/">Deathstroke Co-Creator Praises Joe Manganiello for Justice League</a></h3>
</article>
<article>
<a href="/deathstroke-joe-manganiello-justice-league-photo/">
<picture>
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source media="(min-width: 1024px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 1024px) and (min-resolution: 120dpi)" sizes="386px" data-srcset="https://cdn3.movieweb.com/i/article/qQqkWj8tbAAKXbV2Re1Sff1kQV2PIw/386:50/Deathstroke-Joe-Manganiello-Justice-League-Photo.jpg 579w" />
<source media="(min-width: 1024px)" sizes="386px" data-srcset="https://cdn3.movieweb.com/i/article/qQqkWj8tbAAKXbV2Re1Sff1kQV2PIw/386:50/Deathstroke-Joe-Manganiello-Justice-League-Photo.jpg 386w" />
<source media="(min-width: 768px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 768px) and (min-resolution: 120dpi)" sizes="471px" data-srcset="https://cdn3.movieweb.com/i/article/qQqkWj8tbAAKXbV2Re1Sff1kQV2PIw/471:50/Deathstroke-Joe-Manganiello-Justice-League-Photo.jpg 706w" />
<source media="(min-width: 768px)" sizes="471px" data-srcset="https://cdn3.movieweb.com/i/article/qQqkWj8tbAAKXbV2Re1Sff1kQV2PIw/471:50/Deathstroke-Joe-Manganiello-Justice-League-Photo.jpg 471w" />
<source media="(min-width: 481px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 481px) and (min-resolution: 120dpi)" sizes="737px" data-srcset="https://cdn3.movieweb.com/i/article/qQqkWj8tbAAKXbV2Re1Sff1kQV2PIw/737:50/Deathstroke-Joe-Manganiello-Justice-League-Photo.jpg 1105w" />
<source media="(min-width: 481px)" sizes="737px" data-srcset="https://cdn3.movieweb.com/i/article/qQqkWj8tbAAKXbV2Re1Sff1kQV2PIw/737:50/Deathstroke-Joe-Manganiello-Justice-League-Photo.jpg 737w" />
<source media="(min-width: 0px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 0px) and (min-resolution: 120dpi)" sizes="450px" data-srcset="https://cdn3.movieweb.com/i/article/qQqkWj8tbAAKXbV2Re1Sff1kQV2PIw/450:50/Deathstroke-Joe-Manganiello-Justice-League-Photo.jpg 675w" />
<source media="(min-width: 0px)" sizes="450px" data-srcset="https://cdn3.movieweb.com/i/article/qQqkWj8tbAAKXbV2Re1Sff1kQV2PIw/450:50/Deathstroke-Joe-Manganiello-Justice-League-Photo.jpg 450w" />
<!--[if IE 9]></video><![endif]-->
<img class="lazyload" alt="Joe Manganiello as Deathstroke Officially Revealed in Justice League" />
</picture>
</a>
<h3 class="article-more-links-title" title="Joe Manganiello as Deathstroke Officially Revealed in Justice League"><a href="/deathstroke-joe-manganiello-justice-league-photo/">Joe Manganiello as Deathstroke Officially Revealed in Justice League</a></h3>
</article>
</div>
</section>

<a id="spotim_wrapper"></a>
<div class="ad-spotim-wrapper">
<script async src="https://launcher.spot.im/spot/sp_jrr0VdcJ" data-spotim-module="spotim-launcher" data-post-url="https://movieweb.com/deathstroke-knights-and-dragons-the-movie-trailer/" data-article-tags="Deathstroke,Movies,Movie News" data-post-id="ARxvhSqnnSwABy">
</script>
</div>

<div class="ad ad-video">
</div>
</footer>
</div>
<aside class="sidebar">
<div class="ad">

<div id='div-gpt-ad-1416204122903-4'>
<script>
 googletag.cmd.push(function() {
 googletag.display('div-gpt-ad-1416204122903-4');
 });
</script>
</div>
</div>
<header class="sidebar-heading">
<h2>Trending</h2>
</header>
<div class="sidebar-links">
<article>
<a href="/dinosaurs-tv-sitcom-disney-plus-streaming-fall-2020/">
<h3 class="sidebar-link-heading">Dinosaurs TV Show Is Coming to Disney+ This Fall</h3>
<p class="sidebar-link-category">TV News</p>
<figure class="sidebar-link-figure">
<picture>
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source media="(min-width: 1024px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 1024px) and (min-resolution: 120dpi)" sizes="325px" data-srcset="https://cdn3.movieweb.com/i/article/p81UbbrtSzBHuSOeVtGOJHzGIsuQRp/325:75/Dinosaurs-Tv-Sitcom-Disney-Plus-Streaming-Fall-2020.jpg 487w" />
<source media="(min-width: 1024px)" sizes="325px" data-srcset="https://cdn3.movieweb.com/i/article/p81UbbrtSzBHuSOeVtGOJHzGIsuQRp/325:75/Dinosaurs-Tv-Sitcom-Disney-Plus-Streaming-Fall-2020.jpg 325w" />
<source media="(min-width: 768px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 768px) and (min-resolution: 120dpi)" sizes="471px" data-srcset="https://cdn3.movieweb.com/i/article/p81UbbrtSzBHuSOeVtGOJHzGIsuQRp/471:75/Dinosaurs-Tv-Sitcom-Disney-Plus-Streaming-Fall-2020.jpg 706w" />
<source media="(min-width: 768px)" sizes="471px" data-srcset="https://cdn3.movieweb.com/i/article/p81UbbrtSzBHuSOeVtGOJHzGIsuQRp/471:75/Dinosaurs-Tv-Sitcom-Disney-Plus-Streaming-Fall-2020.jpg 471w" />
<source media="(min-width: 481px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 481px) and (min-resolution: 120dpi)" sizes="737px" data-srcset="https://cdn3.movieweb.com/i/article/p81UbbrtSzBHuSOeVtGOJHzGIsuQRp/737:75/Dinosaurs-Tv-Sitcom-Disney-Plus-Streaming-Fall-2020.jpg 1105w" />
<source media="(min-width: 481px)" sizes="737px" data-srcset="https://cdn3.movieweb.com/i/article/p81UbbrtSzBHuSOeVtGOJHzGIsuQRp/737:75/Dinosaurs-Tv-Sitcom-Disney-Plus-Streaming-Fall-2020.jpg 737w" />
<source media="(min-width: 0px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 0px) and (min-resolution: 120dpi)" sizes="450px" data-srcset="https://cdn3.movieweb.com/i/article/p81UbbrtSzBHuSOeVtGOJHzGIsuQRp/450:75/Dinosaurs-Tv-Sitcom-Disney-Plus-Streaming-Fall-2020.jpg 675w" />
<source media="(min-width: 0px)" sizes="450px" data-srcset="https://cdn3.movieweb.com/i/article/p81UbbrtSzBHuSOeVtGOJHzGIsuQRp/450:75/Dinosaurs-Tv-Sitcom-Disney-Plus-Streaming-Fall-2020.jpg 450w" />
<!--[if IE 9]></video><![endif]-->
<img class="lazyload" alt="Dinosaurs TV Show Is Coming to Disney+ This Fall" />
</picture>
</figure>
</a>
</article>
<span id="nativo2"></span>
<article>
<a href="/lemmy-kilmister-motorhead-biopic-movie/">
<h3 class="sidebar-link-heading">Mot&#246rhead Frontman Lemmy Kilmister Is Getting a Biopic Movie</h3>
<p class="sidebar-link-category">Movie News</p>
<figure class="sidebar-link-figure">
<picture>
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source media="(min-width: 1024px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 1024px) and (min-resolution: 120dpi)" sizes="325px" data-srcset="https://cdn3.movieweb.com/i/article/Yl2OpdWsVzkpLklcZ8F0qtIBtf5xSq/325:75/Lemmy-Kilmister-Motorhead-Biopic-Movie.jpg 487w" />
<source media="(min-width: 1024px)" sizes="325px" data-srcset="https://cdn3.movieweb.com/i/article/Yl2OpdWsVzkpLklcZ8F0qtIBtf5xSq/325:75/Lemmy-Kilmister-Motorhead-Biopic-Movie.jpg 325w" />
<source media="(min-width: 768px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 768px) and (min-resolution: 120dpi)" sizes="471px" data-srcset="https://cdn3.movieweb.com/i/article/Yl2OpdWsVzkpLklcZ8F0qtIBtf5xSq/471:75/Lemmy-Kilmister-Motorhead-Biopic-Movie.jpg 706w" />
<source media="(min-width: 768px)" sizes="471px" data-srcset="https://cdn3.movieweb.com/i/article/Yl2OpdWsVzkpLklcZ8F0qtIBtf5xSq/471:75/Lemmy-Kilmister-Motorhead-Biopic-Movie.jpg 471w" />
<source media="(min-width: 481px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 481px) and (min-resolution: 120dpi)" sizes="737px" data-srcset="https://cdn3.movieweb.com/i/article/Yl2OpdWsVzkpLklcZ8F0qtIBtf5xSq/737:75/Lemmy-Kilmister-Motorhead-Biopic-Movie.jpg 1105w" />
<source media="(min-width: 481px)" sizes="737px" data-srcset="https://cdn3.movieweb.com/i/article/Yl2OpdWsVzkpLklcZ8F0qtIBtf5xSq/737:75/Lemmy-Kilmister-Motorhead-Biopic-Movie.jpg 737w" />
<source media="(min-width: 0px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 0px) and (min-resolution: 120dpi)" sizes="450px" data-srcset="https://cdn3.movieweb.com/i/article/Yl2OpdWsVzkpLklcZ8F0qtIBtf5xSq/450:75/Lemmy-Kilmister-Motorhead-Biopic-Movie.jpg 675w" />
<source media="(min-width: 0px)" sizes="450px" data-srcset="https://cdn3.movieweb.com/i/article/Yl2OpdWsVzkpLklcZ8F0qtIBtf5xSq/450:75/Lemmy-Kilmister-Motorhead-Biopic-Movie.jpg 450w" />
<!--[if IE 9]></video><![endif]-->
<img class="lazyload" alt="Mot&#246rhead Frontman Lemmy Kilmister Is Getting a Biopic Movie" />
</picture>
</figure>
</a>
</article>
<article>
<a href="/avatar-2-resumes-shooting-new-zealand/">
<h3 class="sidebar-link-heading">Avatar 2 Resumes Filming in New Zealand, Producer Shares 'First Day Back' Set Photo</h3>
<p class="sidebar-link-category">Movie News</p>
<figure class="sidebar-link-figure">
<picture>
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source media="(min-width: 1024px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 1024px) and (min-resolution: 120dpi)" sizes="325px" data-srcset="https://cdn3.movieweb.com/i/article/ftdKC9m5CWV73zlEwd8C1n7KQvPWON/325:75/Avatar-2-Resumes-Shooting-New-Zealand.jpg 487w" />
<source media="(min-width: 1024px)" sizes="325px" data-srcset="https://cdn3.movieweb.com/i/article/ftdKC9m5CWV73zlEwd8C1n7KQvPWON/325:75/Avatar-2-Resumes-Shooting-New-Zealand.jpg 325w" />
<source media="(min-width: 768px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 768px) and (min-resolution: 120dpi)" sizes="471px" data-srcset="https://cdn3.movieweb.com/i/article/ftdKC9m5CWV73zlEwd8C1n7KQvPWON/471:75/Avatar-2-Resumes-Shooting-New-Zealand.jpg 706w" />
<source media="(min-width: 768px)" sizes="471px" data-srcset="https://cdn3.movieweb.com/i/article/ftdKC9m5CWV73zlEwd8C1n7KQvPWON/471:75/Avatar-2-Resumes-Shooting-New-Zealand.jpg 471w" />
<source media="(min-width: 481px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 481px) and (min-resolution: 120dpi)" sizes="737px" data-srcset="https://cdn3.movieweb.com/i/article/ftdKC9m5CWV73zlEwd8C1n7KQvPWON/737:75/Avatar-2-Resumes-Shooting-New-Zealand.jpg 1105w" />
<source media="(min-width: 481px)" sizes="737px" data-srcset="https://cdn3.movieweb.com/i/article/ftdKC9m5CWV73zlEwd8C1n7KQvPWON/737:75/Avatar-2-Resumes-Shooting-New-Zealand.jpg 737w" />
<source media="(min-width: 0px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 0px) and (min-resolution: 120dpi)" sizes="450px" data-srcset="https://cdn3.movieweb.com/i/article/ftdKC9m5CWV73zlEwd8C1n7KQvPWON/450:75/Avatar-2-Resumes-Shooting-New-Zealand.jpg 675w" />
<source media="(min-width: 0px)" sizes="450px" data-srcset="https://cdn3.movieweb.com/i/article/ftdKC9m5CWV73zlEwd8C1n7KQvPWON/450:75/Avatar-2-Resumes-Shooting-New-Zealand.jpg 450w" />
<!--[if IE 9]></video><![endif]-->
<img class="lazyload" alt="Avatar 2 Resumes Filming in New Zealand, Producer Shares 'First Day Back' Set Photo" />
</picture>
</figure>
</a>
</article>
<div class="ad">

<div id='div-gpt-ad-1416204122903-2'>
<script>
 googletag.cmd.push(function() {
 googletag.display('div-gpt-ad-1416204122903-2');
 });
</script>
</div>
</div>
<article>
<a href="/uncle-ben-mrs-butterworth-aunt-jemima-rebranding/">
<h3 class="sidebar-link-heading">Uncle Ben's and Mrs. Butterworth's Will Get Rebranded Following Aunt Jemima Retirement</h3>
<p class="sidebar-link-category">Pop Culture</p>
<figure class="sidebar-link-figure">
<picture>
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source media="(min-width: 1024px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 1024px) and (min-resolution: 120dpi)" sizes="325px" data-srcset="https://cdn3.movieweb.com/i/article/4kH7SJMKImUhivpiuXrtOdk07LAmLo/325:75/Uncle-Ben-Mrs-Butterworth-Aunt-Jemima-Rebranding.jpg 487w" />
<source media="(min-width: 1024px)" sizes="325px" data-srcset="https://cdn3.movieweb.com/i/article/4kH7SJMKImUhivpiuXrtOdk07LAmLo/325:75/Uncle-Ben-Mrs-Butterworth-Aunt-Jemima-Rebranding.jpg 325w" />
<source media="(min-width: 768px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 768px) and (min-resolution: 120dpi)" sizes="471px" data-srcset="https://cdn3.movieweb.com/i/article/4kH7SJMKImUhivpiuXrtOdk07LAmLo/471:75/Uncle-Ben-Mrs-Butterworth-Aunt-Jemima-Rebranding.jpg 706w" />
<source media="(min-width: 768px)" sizes="471px" data-srcset="https://cdn3.movieweb.com/i/article/4kH7SJMKImUhivpiuXrtOdk07LAmLo/471:75/Uncle-Ben-Mrs-Butterworth-Aunt-Jemima-Rebranding.jpg 471w" />
<source media="(min-width: 481px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 481px) and (min-resolution: 120dpi)" sizes="737px" data-srcset="https://cdn3.movieweb.com/i/article/4kH7SJMKImUhivpiuXrtOdk07LAmLo/737:75/Uncle-Ben-Mrs-Butterworth-Aunt-Jemima-Rebranding.jpg 1105w" />
<source media="(min-width: 481px)" sizes="737px" data-srcset="https://cdn3.movieweb.com/i/article/4kH7SJMKImUhivpiuXrtOdk07LAmLo/737:75/Uncle-Ben-Mrs-Butterworth-Aunt-Jemima-Rebranding.jpg 737w" />
<source media="(min-width: 0px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 0px) and (min-resolution: 120dpi)" sizes="450px" data-srcset="https://cdn3.movieweb.com/i/article/4kH7SJMKImUhivpiuXrtOdk07LAmLo/450:75/Uncle-Ben-Mrs-Butterworth-Aunt-Jemima-Rebranding.jpg 675w" />
<source media="(min-width: 0px)" sizes="450px" data-srcset="https://cdn3.movieweb.com/i/article/4kH7SJMKImUhivpiuXrtOdk07LAmLo/450:75/Uncle-Ben-Mrs-Butterworth-Aunt-Jemima-Rebranding.jpg 450w" />
<!--[if IE 9]></video><![endif]-->
<img class="lazyload" alt="Uncle Ben's and Mrs. Butterworth's Will Get Rebranded Following Aunt Jemima Retirement" />
</picture>
</figure>
</a>
</article>
<article>
<a href="/danny-masterson-rape/">
<h3 class="sidebar-link-heading">Danny Masterson Charged with Raping 3 Women, Faces Up to 45 Years in Prison</h3>
<p class="sidebar-link-category">TV News</p>
<figure class="sidebar-link-figure">
<picture>
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source media="(min-width: 1024px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 1024px) and (min-resolution: 120dpi)" sizes="325px" data-srcset="https://cdn3.movieweb.com/i/article/OASsA901y0xBv7wZOq9hENBVAC1xPs/325:75/Danny-Masterson-Rape.jpg 487w" />
<source media="(min-width: 1024px)" sizes="325px" data-srcset="https://cdn3.movieweb.com/i/article/OASsA901y0xBv7wZOq9hENBVAC1xPs/325:75/Danny-Masterson-Rape.jpg 325w" />
<source media="(min-width: 768px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 768px) and (min-resolution: 120dpi)" sizes="471px" data-srcset="https://cdn3.movieweb.com/i/article/OASsA901y0xBv7wZOq9hENBVAC1xPs/471:75/Danny-Masterson-Rape.jpg 706w" />
<source media="(min-width: 768px)" sizes="471px" data-srcset="https://cdn3.movieweb.com/i/article/OASsA901y0xBv7wZOq9hENBVAC1xPs/471:75/Danny-Masterson-Rape.jpg 471w" />
<source media="(min-width: 481px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 481px) and (min-resolution: 120dpi)" sizes="737px" data-srcset="https://cdn3.movieweb.com/i/article/OASsA901y0xBv7wZOq9hENBVAC1xPs/737:75/Danny-Masterson-Rape.jpg 1105w" />
<source media="(min-width: 481px)" sizes="737px" data-srcset="https://cdn3.movieweb.com/i/article/OASsA901y0xBv7wZOq9hENBVAC1xPs/737:75/Danny-Masterson-Rape.jpg 737w" />
<source media="(min-width: 0px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 0px) and (min-resolution: 120dpi)" sizes="450px" data-srcset="https://cdn3.movieweb.com/i/article/OASsA901y0xBv7wZOq9hENBVAC1xPs/450:75/Danny-Masterson-Rape.jpg 675w" />
<source media="(min-width: 0px)" sizes="450px" data-srcset="https://cdn3.movieweb.com/i/article/OASsA901y0xBv7wZOq9hENBVAC1xPs/450:75/Danny-Masterson-Rape.jpg 450w" />
<!--[if IE 9]></video><![endif]-->
<img class="lazyload" alt="Danny Masterson Charged with Raping 3 Women, Faces Up to 45 Years in Prison" />
</picture>
</figure>
</a>
</article>
</div>
<div class="sidebar-sticky">
<div class="ad">

<div id='div-gpt-ad-1416204122903-3'>
<script>
 googletag.cmd.push(function() {
 googletag.display('div-gpt-ad-1416204122903-3');
 });
</script>
</div>
</div>
<section class="sidebar-sticky-items">
<header class="sidebar-heading">
<h2>Movie News</h2>
</header>
<div class="sidebar-sticky-items">
<article class="sidebar-sticky-link">
<a href="/spencer-movie-kristen-stewart-princess-di/">
<figure class="sidebar-sticky-link-figure">
<picture>
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source media="(min-width: 1024px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 1024px) and (min-resolution: 120dpi)" sizes="122px" data-srcset="https://cdn3.movieweb.com/i/article/gavoWy4ydTy5mvGevqu1TuX4HMinJZ/122:50/Spencer-Movie-Kristen-Stewart-Princess-Di.jpg 183w" />
<source media="(min-width: 1024px)" sizes="122px" data-srcset="https://cdn3.movieweb.com/i/article/gavoWy4ydTy5mvGevqu1TuX4HMinJZ/122:50/Spencer-Movie-Kristen-Stewart-Princess-Di.jpg 122w" />
<source media="(min-width: 768px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 768px) and (min-resolution: 120dpi)" sizes="337px" data-srcset="https://cdn3.movieweb.com/i/article/gavoWy4ydTy5mvGevqu1TuX4HMinJZ/337:50/Spencer-Movie-Kristen-Stewart-Princess-Di.jpg 505w" />
<source media="(min-width: 768px)" sizes="337px" data-srcset="https://cdn3.movieweb.com/i/article/gavoWy4ydTy5mvGevqu1TuX4HMinJZ/337:50/Spencer-Movie-Kristen-Stewart-Princess-Di.jpg 337w" />
<source media="(min-width: 481px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 481px) and (min-resolution: 120dpi)" sizes="257px" data-srcset="https://cdn3.movieweb.com/i/article/gavoWy4ydTy5mvGevqu1TuX4HMinJZ/257:50/Spencer-Movie-Kristen-Stewart-Princess-Di.jpg 385w" />
<source media="(min-width: 481px)" sizes="257px" data-srcset="https://cdn3.movieweb.com/i/article/gavoWy4ydTy5mvGevqu1TuX4HMinJZ/257:50/Spencer-Movie-Kristen-Stewart-Princess-Di.jpg 257w" />
<source media="(min-width: 0px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 0px) and (min-resolution: 120dpi)" sizes="157px" data-srcset="https://cdn3.movieweb.com/i/article/gavoWy4ydTy5mvGevqu1TuX4HMinJZ/157:50/Spencer-Movie-Kristen-Stewart-Princess-Di.jpg 235w" />
<source media="(min-width: 0px)" sizes="157px" data-srcset="https://cdn3.movieweb.com/i/article/gavoWy4ydTy5mvGevqu1TuX4HMinJZ/157:50/Spencer-Movie-Kristen-Stewart-Princess-Di.jpg 157w" />
<!--[if IE 9]></video><![endif]-->
<img class="lazyload" alt="Kristen Stewart Is Princess Diana in Pablo Larra&#237n's Spencer" />
</picture>
</figure>
</a>
<h3 class="sidebar-sticky-link-heading"><a href="/spencer-movie-kristen-stewart-princess-di/" title="Kristen Stewart Is Princess Diana in Pablo Larra&#237n's Spencer">Kristen Stewart Is Princess Diana in Pablo Larra&#237n's Spencer</a></h3>
</article>
<article class="sidebar-sticky-link">
<a href="/star-wars-tv-shows-interconnected-disney-plus/">
<figure class="sidebar-sticky-link-figure">
<picture>
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source media="(min-width: 1024px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 1024px) and (min-resolution: 120dpi)" sizes="122px" data-srcset="https://cdn3.movieweb.com/i/article/VF93hodTpKDw9ThxpfcuoMITx8fxlU/122:50/Star-Wars-Tv-Shows-Interconnected-Disney-Plus.jpg 183w" />
<source media="(min-width: 1024px)" sizes="122px" data-srcset="https://cdn3.movieweb.com/i/article/VF93hodTpKDw9ThxpfcuoMITx8fxlU/122:50/Star-Wars-Tv-Shows-Interconnected-Disney-Plus.jpg 122w" />
<source media="(min-width: 768px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 768px) and (min-resolution: 120dpi)" sizes="337px" data-srcset="https://cdn3.movieweb.com/i/article/VF93hodTpKDw9ThxpfcuoMITx8fxlU/337:50/Star-Wars-Tv-Shows-Interconnected-Disney-Plus.jpg 505w" />
<source media="(min-width: 768px)" sizes="337px" data-srcset="https://cdn3.movieweb.com/i/article/VF93hodTpKDw9ThxpfcuoMITx8fxlU/337:50/Star-Wars-Tv-Shows-Interconnected-Disney-Plus.jpg 337w" />
<source media="(min-width: 481px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 481px) and (min-resolution: 120dpi)" sizes="257px" data-srcset="https://cdn3.movieweb.com/i/article/VF93hodTpKDw9ThxpfcuoMITx8fxlU/257:50/Star-Wars-Tv-Shows-Interconnected-Disney-Plus.jpg 385w" />
<source media="(min-width: 481px)" sizes="257px" data-srcset="https://cdn3.movieweb.com/i/article/VF93hodTpKDw9ThxpfcuoMITx8fxlU/257:50/Star-Wars-Tv-Shows-Interconnected-Disney-Plus.jpg 257w" />
<source media="(min-width: 0px) and (-webkit-min-device-pixel-ratio: 1.25), (min-width: 0px) and (min-resolution: 120dpi)" sizes="157px" data-srcset="https://cdn3.movieweb.com/i/article/VF93hodTpKDw9ThxpfcuoMITx8fxlU/157:50/Star-Wars-Tv-Shows-Interconnected-Disney-Plus.jpg 235w" />
<source media="(min-width: 0px)" sizes="157px" data-srcset="https://cdn3.movieweb.com/i/article/VF93hodTpKDw9ThxpfcuoMITx8fxlU/157:50/Star-Wars-Tv-Shows-Interconnected-Disney-Plus.jpg 157w" />
<!--[if IE 9]></video><![endif]-->
<img class="lazyload" alt="Is Disney+ Planning a Bunch of Star Wars Interconnected Live-Action TV Shows for 2021?" />
</picture>
</figure>
</a>
<h3 class="sidebar-sticky-link-heading"><a href="/star-wars-tv-shows-interconnected-disney-plus/" title="Is Disney+ Planning a Bunch of Star Wars Interconnected Live-Action TV Shows for 2021?">Is Disney+ Planning a Bunch of Star Wars Interconnected Live-Action TV Shows for 2021?</a></h3>
</article>
</div>
</section>
</div>
</aside>
</div>
</main>
<div class="ad-leaderboard ad-leaderboard-wrap">

<div id='div-gpt-ad-1416204122903-0'>
<script>
 googletag.cmd.push(function() {
 googletag.display('div-gpt-ad-1416204122903-0');
 });
</script>
</div>
</div>
<footer class="site-footer">
<div class="site-footer-social">
<ul class="site-footer-social-links">
<li>
<a href="https://movieweb.com/rss/" class="site-footer-feed"><span>Feed</span></a>
</li>
<li>
<a href="https://www.facebook.com/movieweb/" class="site-footer-facebook"><span>Facebook</span></a>
</li>
<li>
<a href="https://twitter.com/intent/follow?source=followbutton&variant=1.0&screen_name=movieweb&original_referer=https://movieweb.com/deathstroke-knights-and-dragons-the-movie-trailer/" class="site-footer-twitter"><span>Twitter</span></a>
</li>
<li>
<a href="https://www.instagram.com/movieweb/" class="site-footer-instagram"><span>Instagram</span></a>
</li>
<li>
<a href="https://www.youtube.com/movieweb?sub_confirmation=1" class="site-footer-youtube"><span>YouTube</span></a>
</li>
</ul>
</div>
<div class="site-footer-info">
<ul class="site-footer-info-links">
<li><a href="https://movieweb.com/about/">About</a></li>
<li><a href="https://movieweb.com/privacy/">Privacy</a></li>
<li><a href="https://movieweb.com/terms/">Terms</a></li>
<li><a href="https://movieweb.com/contact/">Contact</a></li>
</ul>
<p class="site-footer-copyright"><small>&copy; Watchr Media &bullet; All rights reserved</small></p>
</div>
</footer>
<div class="hidden">

<div id='div-gpt-ad-1416695535258-0-oop'>
<script>
 googletag.cmd.push(function() {
 googletag.display('div-gpt-ad-1416695535258-0-oop');
 });
</script>
</div>
</div>
<div class="hidden">
<script>
 !function(){top.ggproducts=[1];var a,b="e06f871c",c="https://g2.gumgum.com/javascripts/ggv2.js",d=top,e="script",f=d.document,g=f.getElementsByTagName(e)[0],h=d.XMLHttpRequest||d.XDomainRequest,i=function(a){var b=f.createElement(e);b.src=a,b.async=!0,g.parentNode.insertBefore(b,g)},j=function(){d.clearTimeout(a)};return d.ggv2id=b,h?(h=new h,h.open("GET",c),h.onload=function(){j();try{(d.execScript||function(a){d.eval.call(d,a)})(h.responseText)}catch(a){}},a=d.setTimeout(function(){h.abort()},3e3),void h.send()):i(c)}();
</script>
<script src="//s.ntv.io/serve/load.js" async></script>
</div>
<script src="/assets/5ee48a15ae0f1/sites/sites-main/js/app2.min.js"></script>

<script>
 var _comscore = _comscore || [];
 _comscore.push({ c1: "2", c2: "17091571" });
 (function() {
 var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
 s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
 el.parentNode.insertBefore(s, el);
 })();
</script>
<noscript>
<img src="https://sb.scorecardresearch.com/p?c1=2&c2=17091571&cv=2.0&cj=1" alt="comscore" />
</noscript>


<script>
 _atrk_opts = { atrk_acct:"4fQco1IWNa10zK", domain:"movieweb.com",dynamic: true};
 (function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=4fQco1IWNa10zK" style="display:none" height="1" width="1" alt="alexa" /></noscript>
<script>docReady();</script>

<script type="text/javascript" id="dm-script" src="https://tag.durationmedia.net/sites/10413/dm.js" charset="utf-8" async></script>
</body>
</html>