<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><title>70 Breathtaking Han Solo Images Reveal New Star Wars Characters - MovieWeb</title><meta name="description" content="A ton of new faces have just been introduced in the official Solo: A Star Wars Story trailer, which we break down with all new images."><meta http-equiv="X-UA-Compatible" content="IE=edge"><link rel="profile" href="http://gmpg.org/xfn/11" /><link rel="publisher" href="https://plus.google.com/+movieweb/posts" /><meta property="og:locale" content="en_US" /><meta property="og:site_name" content="MovieWeb" /><meta property="fb:app_id" content="357878074202" /><meta property="fb:pages" content="46132502198" /><meta property="fb:admins" content="701427497" /><meta property="fb:admins" content="804274940" /><meta property="fb:admins" content="1295310549" /><meta name="twitter:domain" content="movieweb.com"><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://feedproxy.google.com/movieweb_news" /><meta name="robots" content="noodp" /><meta name="robots" content="noydir" /><link rel="canonical" href="https://movieweb.com/han-solo-movie-photos-new-star-wars-trailer-images/" /><link rel="amphtml" href="https://movieweb.com/amp/han-solo-movie-photos-new-star-wars-trailer-images/" /><link rel="image_src" href="https://cdn.movieweb.com/img.news.tops/NEpqbMZJTfwrts_1_a/Han-Solo-Movie-Photos-New-Star-Wars-Trailer.jpg"><meta name="news_keywords" content="Han Solo,Star Wars,Solo: A Star Wars Story,Movie News" /><meta property="og:type" content="article" /><meta property="og:title" content="70 Breathtaking Han Solo Images Reveal New Star Wars Characters" /><meta property="og:url" content="https://movieweb.com/han-solo-movie-photos-new-star-wars-trailer-images/" /><meta property="og:description" content="A ton of new faces have just been introduced in the official Solo: A Star Wars Story trailer, which we break down with all new images."><meta property="og:image" content="https://cdn.movieweb.com/img.news.tops/NEpqbMZJTfwrts_1_a/Han-Solo-Movie-Photos-New-Star-Wars-Trailer.jpg" /><meta name="twitter:title" content="70 Breathtaking Han Solo Images Reveal New Star Wars Characters"><meta name="twitter:description" content="A ton of new faces have just been introduced in the official Solo: A Star Wars Story trailer, which we break down with all new images."><meta name="twitter:card" content="photo" /><meta name="twitter:image" content="https://cdn.movieweb.com/img.news.tops/NEpqbMZJTfwrts_1_a/Han-Solo-Movie-Photos-New-Star-Wars-Trailer.jpg" /><meta name="twitter:image:alt" content="70 Breathtaking Han Solo Images Reveal New Star Wars Characters" /><meta name="twitter:url" content="https://movieweb.com/han-solo-movie-photos-new-star-wars-trailer-images/"><meta name="twitter:site" content="@movieweb" /><meta property="article:publisher" content="https://www.facebook.com/movieweb/" /><meta property="article:published_time" content="2018-02-05T07:30:05-08:00" /><meta property="article:modified_time" content="2018-02-05T07:30:05-08:00" /><meta property="article:section" content="Movie News" /><meta property="article:tag" content="Han Solo" /><meta property="article:tag" content="Star Wars" /><meta property="article:tag" content="Solo: A Star Wars Story" /><meta property="article:tag" content="Movie News" /><link rel="author" href="https://plus.google.com/102865999851910514583"><link rel="dns-prefetch" href="//cdn.movieweb.com"><link rel="dns-prefetch" href="//www.google-analytics.com"><link rel="dns-prefetch" href="https://ajax.googleapis.com"><link rel="dns-prefetch" href="//fonts.typonine.com/"><link rel="dns-prefetch" href="//c.amazon-adsystem.com"><link rel="dns-prefetch" href="//www.googletagservices.com"><link rel="dns-prefetch" href="//ap.lijit.com"><link rel="dns-prefetch" href="//gslbeacon.lijit.com"><link rel="manifest" href="/manifest.json"><meta name="mobile-web-app-capable" content="yes"><meta name="application-name" content="MovieWeb"><meta name="msapplication-TileColor" content="#cc0000"><meta name="msapplication-TileImage" content="//cdn.movieweb.com/assets/5a7441216e9cc/sites/movieweb.com/icons/mstile-144x144.png"><meta name="theme-color" content="#ffffff"><link rel="apple-touch-icon" sizes="144x144" href="//cdn.movieweb.com/assets/5a7441216e9cc/sites/movieweb.com/icons/apple-touch-icon-144x144.png" /><link rel="apple-touch-icon" sizes="114x114" href="//cdn.movieweb.com/assets/5a7441216e9cc/sites/movieweb.com/icons/apple-touch-icon-114x114.png" /><link rel="apple-touch-icon" sizes="72x72" href="//cdn.movieweb.com/assets/5a7441216e9cc/sites/movieweb.com/icons/apple-touch-icon-72x72.png" /><link rel="apple-touch-icon" sizes="57x57" href="//cdn.movieweb.com/assets/5a7441216e9cc/sites/movieweb.com/icons/apple-touch-icon-57x57.png" /><link rel="apple-touch-icon" href="//cdn.movieweb.com/assets/5a7441216e9cc/sites/movieweb.com/icons/apple-touch-icon-57x57.png" /><link rel="shortcut icon" href="//cdn.movieweb.com/assets/5a7441216e9cc/sites/movieweb.com/icons/favicon.ico" type="image/x-icon"><link rel="icon" href="//cdn.movieweb.com/assets/5a7441216e9cc/sites/movieweb.com/icons/favicon.ico" type="image/x-icon"><script> var site_domain = 'movieweb.com'; var device_type = 'desktop'; var news_type = 'article'; </script><script>(function(a,b,c,d,e){e=a.createElement(b);a=a.getElementsByTagName(b)[0];e.async=1;e.src=c;a.parentNode.insertBefore(e,a)})(document,'script','//separatesilver.com/0cbf0251db822e69a4eb820faba60d9d15182d6431a69fa1232f810a7147d0a820c3ec420e7a9df509903d130b95744b0749dc31a93b145d25fadd58491b');</script><script src="//cdn.movieweb.com/assets/5a7441216e9cc/sites/movieweb.com/ads.hb.v5.min.js"></script><script type='text/javascript'> googletag.cmd.push(function() { googletag.pubads().setTargeting("type", "news"); var banner_ros_square_right4 = googletag.defineSlot('/1007926/MW_ROS_MID3_300', [300, 250], 'div-gpt-ad-1416204122903-6').addService(googletag.pubads()); var banner_leader_728x90 = googletag.defineSlot('/1007926/MW_ROS_ATF_728_320_Leader', [728, 90], 'div-gpt-ad-1416204122903-7').addService(googletag.pubads()); googletag.pubads().setTargeting("has_video", "no"); var banner_video_news = googletag.defineSlot('/1007926/MW_News_Video_Unit', [[430, 343], [336, 280], [300, 250]], 'div-gpt-ad-1416204363531-0').addService(googletag.pubads()); var banner_ros_square_right1 = googletag.defineSlot('/1007926/MW_ROS_Right_ATF_300x250', [[300, 250], [300, 600], [300, 1050]], 'div-gpt-ad-1416204122903-4').addService(googletag.pubads()); var banner_ros_square_right2 = googletag.defineSlot('/1007926/MW_ROS_MID1_300', [[300, 250], [300, 600], [300, 1050]], 'div-gpt-ad-1416204122903-2').addService(googletag.pubads()); var banner_ros_square_right3 = googletag.defineSlot('/1007926/MW_ROS_MID2_300', [[300, 250], [300, 600], [300, 1050]], 'div-gpt-ad-1416204122903-3').addService(googletag.pubads()); var banner_leader_combined_mapping = googletag.sizeMapping(). addSize([1400, 250], [[1000,200], [970, 250], [970, 90], [728, 90], [320, 50]]). addSize([1170, 250], [[728, 90], [320, 50]]). addSize([1024, 250], [320, 50]). addSize([728, 250], [[728, 90], [320, 50]]). addSize([0, 0], [320,50]).build(); var banner_leader_combined = googletag.defineSlot('/1007926/MW_ROS_ATF_Combined_Leader', [[320, 50], [728, 90], [970, 90], [970, 250], [1000,200]], 'div-gpt-ad-1416204122903-0'). defineSizeMapping(banner_leader_combined_mapping). addService(googletag.pubads()); pbjs.que.push(function() { pbjs.setTargetingForGPTAsync() }); googletag.pubads().setTargeting("page", [window.location.pathname.replace("/", "")]); googletag.pubads().setCentering(true); googletag.pubads().collapseEmptyDivs(true); googletag.pubads().enableSingleRequest(); googletag.enableServices(); }); </script><script type="text/javascript"> _atrk_opts = { atrk_acct:"4fQco1IWNa10zK", domain:"movieweb.com",dynamic: true}; (function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })(); </script><script type="application/ld+json"> { "@context" : "http://schema.org", "@type" : "Organization", "name" : "MovieWeb", "url" : "https://movieweb.com", "logo": "https://cdn.movieweb.com/assets/5a7441216e9cc/sites/movieweb.com/logo-amp.png" } </script><link rel="stylesheet" href="//cdn.movieweb.com/assets/5a7441216e9cc/sites/movieweb.com/main.min.css?5a7441216e9cc"><!--[if lte IE 9]><script src="//cdn.movieweb.com/assets/5a7441216e9cc/sites/sites-main/js/html5shiv.min.js"></script><script src="//cdn.movieweb.com/assets/5a7441216e9cc/sites/sites-main/js/rem.min.js"></script><link rel="stylesheet" href="//cdn.movieweb.com/assets/5a7441216e9cc/sites/sites-main/css/ie8-9.min.css"><![endif]--></head><body><header class="site-header"><div class="inner"><div class="site-title"><a href="https://movieweb.com" class="site-logo">MovieWeb</a></div><button class="site-nav-button"><span>Menu</span></button><nav class="site-nav" itemscope itemtype="http://schema.org/SiteNavigationElement"><div class="site-nav-social"><ul class="site-nav-social-items"><li class="site-nav-social-facebook"><a href="https://www.facebook.com/movieweb/" target="_blank"><span>Facebook</span></a></li><li class="site-nav-social-twitter"><a href="https://twitter.com/intent/follow?source=followbutton&variant=1.0&screen_name=movieweb&original_referer=https://movieweb.com/han-solo-movie-photos-new-star-wars-trailer-images/" target="_blank"><span>Twitter</span></a></li><li class="site-nav-social-google-plus"><a href="https://plus.google.com/+movieweb/posts" target="_blank"><span>Google+</span></a></li><li class="site-nav-social-youtube"><a href="https://www.youtube.com/user/movieweb?sub_confirmation=1" target="_blank"><span>YouTube</span></a></li><li class="site-nav-social-feed"><a href="https://movieweb.com/rss/"><span>Feed</span></a></li></ul></div><div class="site-nav-content"><ul class="site-nav-content-items"><li itemprop="name"><a href="https://movieweb.com/movie-news/" itemprop="url">Movie News</a></li><li itemprop="name"><a href="https://movieweb.com/new-movies/" itemprop="url">New Movies</a></li><li itemprop="name"><a href="https://movieweb.com/movie-trailers/" itemprop="url">Movie Trailers</a></li><li itemprop="name"><a href="https://movieweb.com/movie-reviews/" itemprop="url">Movie Reviews</a></li><li itemprop="name"><a href="https://movieweb.com/tv-news/" itemprop="url">TV News</a></li><li itemprop="name"><a href="https://movieweb.com/superheroes/" itemprop="url">Superheroes</a></li></ul></div></nav><div class="current-article-header"><div class="current-article-site-title"><img src="https://cdn.movieweb.com/assets/1/sites/movieweb.com/logo-small.png" alt="MovieWeb"></div><div class="current-article-overview"><p class="current-article-title">70 Breathtaking Han Solo Images Reveal New Star Wars Characters</p></div><ul class="current-article-actions"><li><button class="current-article-button current-article-button-facebook facebook"><span class="current-article-button-facebook-label-share">Share</span></button></li><li><button class="current-article-button current-article-button-comments" data-toggle="comments"><span class="current-article-button-comments-label-comments">Comments</span><span class="current-article-button-comments-label-count"></span></button></li></ul></div><div class="site-search"><button type="button" class="site-search-open-button" data-toggle="site-search-form"><span>Search</span></button><form id="site-search-form" class="site-search-form" data-toggle-focus="site-search-input" action="/search/"><input type="hidden" name="cx" value="002976262196911623014:ycta8t2-kmy"><input type="hidden" name="cof" value="FORID:9"><input type="hidden" name="ie" value="UTF-8"><button type="button" class="site-search-close-button" data-close="site-search-form"><span>Close</span></button><input id="site-search-input" type="search" class="site-search-input" name="q" placeholder="Find Movies &amp; TV Shows" autocomplete="off"><button type="submit" class="site-search-submit-button"><span>Search</span></button></form></div></div></header><main class="main page-articles"><div class="inner"><div class="article-list"><script type="application/ld+json"> { "@context": "http://schema.org", "@type": "Article", "url": "https://movieweb.com/han-solo-movie-photos-new-star-wars-trailer-images/", "mainEntityOfPage": "https://movieweb.com/han-solo-movie-photos-new-star-wars-trailer-images/", "dateCreated": "2018-02-05T07:30:05-08:00", "datePublished": "2018-02-05T07:30:05-08:00", "dateModified": "2018-02-05T07:30:05-08:00", "headline": "70 Breathtaking Han Solo Images Reveal New Star Wars Characters", "description": "A ton of new faces have just been introduced in the official Solo: A Star Wars Story trailer, which we break down with all new images.", "keywords": [ "Han Solo","Star Wars","Solo: A Star Wars Story" ], "image": { "@type": "ImageObject", "url": "https://cdn.movieweb.com/img.news.tops/NEpqbMZJTfwrts_1_a/Han-Solo-Movie-Photos-New-Star-Wars-Trailer.jpg", "height": 632, "width": 1200 }, "author": { "@type": "Person", "name": "B. Alan Orange", "url": "https://movieweb.com/contributors/b-alan-orange/" }, "publisher": { "@type": "Organization", "name": "MovieWeb", "logo": { "@type": "ImageObject", "url": "https://cdn.movieweb.com/assets/5a7441216e9cc/sites/movieweb.com/logo-amp.png", "width": 293, "height": 60 } }, "articleBody": "Did you watch the Solo trailer yet? Fans are going mad over this first look footage, which gives us our best look yet at Alden Ehrenreich as the title character. And fans seem torn. Is he Han Solo? Is he just a guy playing Han Solo? Is he awful, is he good, is he great? The verdict is wildly all over the board. Perhaps we shouldn't focus on that so much right now, as the actor comes into his own playing perhaps one of the most iconic characters in any medium. This delightful 90 second teaser introduces us to a new side of the Star Wars universe we've never seen. And it's quite breathtaking. First up, we finally get to see Donald Glover in action as Lando Calrissian and Joonas Suotamo as the younger Chewbacca, who is wearing two bandoliers this time out as opposed to the more iconic one-strap. How else is Disney going to sell more action figures? We also meet Emilia Clarke's character&#160Qi'Ra for the first time. And see that she is a friend of Han, whom we've yet to hear much about in this galaxy far, far away. It's safe to assume she has passed on by the time the original trilogy rolls around, or perhaps she flew off to the other side of the galaxy to get as far away from Han and his friends as possible. Woody Harrelson is introduced as Tobias Beckett. We get to see him recruiting Han Solo into his merry band of thieves which also include Lando and an alien who many are mistaking for Maz Kanata. Though the Maz twin goes by quick if you look close, this alien has four arms. We're pretty sure it's not Maz, but perhaps she had two of her limbs ripped off by a rage-filled wookie at some point and then dried up like a raison? Also seen here is the droid played by Phoebe Waller-Bridge and another member of the crew played by Thandie Newton. Paul Bettany isn't revealed just yet, but he's not the main villain as far as we can tell. That distinction, outside of the Imperial troops hot on Han's tail, belongs to the badass looking Moloch, who wears a mask like a good portion of the best Star Wars villains. This binary individual remains a true mystery at the moment, but the evil warrior sure looks pretty cool. There are plenty of new ships, blasters and planets teased in this first trailer, which dropped on Good Morning America at 5 am this morning. Though we have yet to get an official word on a lot of what we're seeing here. We've pulled out a number of the best images from the trailer along with some official images that LucasFilm sent over. They also provided us with an official synopsis. 'Board the Millennium Falcon and journey to a galaxy far, far away in 'Solo: A&#160Star Wars&#160Story,' an all-new adventure with the most beloved scoundrel in the&#160galaxy.&#160Through a series of daring escapades deep within a dark and dangerous criminal underworld, Han Solo befriends his mighty future copilot Chewbacca and meets the notorious gambler Lando Calrissian, in a journey that will set the course of one of the&#160Star Wars&#160saga's most unlikely heroes.' Join Han Solo, Lando Calrissian, Qi'ra and Chewbacca as they set off on an all-new journey across the Star Wars universe. We've included all of the images here along with the trailer in case you missed the first couple of rounds it's been shared, all courtesy of Disney and Lucafilm." } </script><article class="article"><header class="article-header" data-newsid="NEpqbMZJTfwrts" data-loadmore="true" data-newscategory="Announcement" data-title="70 Breathtaking Han Solo Images Reveal New Star Wars Characters" data-image="https%3A%2F%2Fcdn.movieweb.com%2Fimg.news.tops%2FNEpqbMZJTfwrts_1_a%2FHan-Solo-Movie-Photos-New-Star-Wars-Trailer.jpg" data-url="https%3A%2F%2Fmovieweb.com%2Fhan-solo-movie-photos-new-star-wars-trailer-images%2F" data-shares="539" data-fbappid="357878074202"><figure class="article-header-figure"><img src="https://cdn.movieweb.com/img.news.tops/NEpqbMZJTfwrts_1_b/Han-Solo-Movie-Photos-New-Star-Wars-Trailer.jpg" alt="A ton of new faces have just been introduced in the official Solo: A Star Wars Story trailer, which we break down with all new images."></figure><div class="article-header-info"><h1 class="article-header-title">70 Breathtaking Han Solo Images Reveal New Star Wars Characters</h1><div class="article-header-credits"><p class="article-header-author"><a href="https://movieweb.com/contributors/b-alan-orange/">B. Alan Orange</a></p><p class="article-header-date"><time datetime="2018-02-05T07:30:05-08:00">02.05.2018</time></p></div></div><ul class="article-header-social"><li class="article-header-social-shares"><span class="article-header-social-shares-count">539</span><span class="article-header-social-shares-label">shares</span></li><li class="article-header-social-item article-header-facebook facebook"><a href="#"><span>Facebook</span></a></li><li class="article-header-social-item article-header-twitter twitter"><a href="#"><span>Twitter</span></a></li><li class="article-header-social-item article-header-google-plus google-plus"><a href="#"><span>Google+</span></a></li><li class="article-header-social-item article-header-email email"><a href="#"><span>Email</span></a></li><li class="article-header-social-item article-header-comment comment"><a href="#" data-toggle="comments"><span>Comment</span></a></li></ul></header><div class="ad-leaderboard-news ad-leaderboard-wrap"><div id='div-gpt-ad-1416204122903-7' style='height:90px; width:728px;'><script> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416204122903-7'); }); </script></div></div><div class="article-body"><p>Did you watch the <a href="https://movieweb.com/movie/solo-a-star-wars-story/" class="movie">Solo</a> trailer yet? Fans are going mad over this <a href="https://movieweb.com/solo-star-wars-story-trailer/" class="news">first look footage</a>, which gives us our best look yet at <em>Alden Ehrenreich</em> as the title character. And fans seem torn. Is he Han Solo? Is he just a guy playing Han Solo? Is he awful, is he good, is he great? The verdict is wildly all over the board. Perhaps we shouldn't focus on that so much right now, as the actor comes into his own playing perhaps one of the most iconic characters in any medium. This delightful 90 second teaser introduces us to a new side of the <em>Star Wars</em> universe we've never seen. And it's quite breathtaking.</p><div class="ad ad-news"><div id='div-gpt-ad-1416204122903-6'><script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416204122903-6'); }); </script></div></div><p>First up, we finally get to see Donald Glover in action as <a href="https://movieweb.com/solo-movie-images-super-bowl-commerical/" class="news">Lando Calrissian</a> and <em>Joonas Suotamo</em> as the younger Chewbacca, who is wearing two bandoliers this time out as opposed to the more iconic one-strap. How else is Disney going to sell more action figures? We also meet Emilia Clarke's character&#160<a href="https://movieweb.com/han-solo-movie-posters-characters-star-wars/" class="news">Qi'Ra</a> for the first time. And see that she is a friend of Han, whom we've yet to hear much about in this galaxy far, far away. It's safe to assume she has passed on by the time the original trilogy rolls around, or perhaps she flew off to the other side of the galaxy to get as far away from Han and his friends as possible.</p><p>Woody Harrelson is introduced as Tobias Beckett. We get to see him recruiting Han Solo into his merry band of thieves which also include Lando and an alien who many are mistaking for Maz Kanata. Though the Maz twin goes by quick if you look close, this alien has four arms. We're pretty sure it's not Maz, but perhaps she had two of her limbs ripped off by a rage-filled wookie at some point and then dried up like a raison? Also seen here is the droid played by Phoebe Waller-Bridge and another member of the crew played by Thandie Newton.</p><p>Paul Bettany isn't revealed just yet, but he's not the main villain as far as we can tell. That distinction, outside of the Imperial troops hot on Han's tail, belongs to the badass looking Moloch, who wears a mask like a good portion of the best <em>Star Wars</em> villains. This binary individual remains a true mystery at the moment, but the evil warrior sure looks pretty cool.</p><p>There are <a href="https://movieweb.com/han-solo-movie-super-bowl-trailer/" class="news">plenty of new ships, blasters and planets</a> teased in this first trailer, which dropped on <em>Good Morning America</em> at 5 am this morning. Though we have yet to get an official word on a lot of what we're seeing here. We've pulled out a number of the best images from the trailer along with some official images that LucasFilm sent over. They also provided us with an official synopsis.</p><blockquote class="quote">"Board the Millennium Falcon and journey to a galaxy far, far away in "Solo: A&#160Star Wars&#160Story," an all-new adventure with the most beloved scoundrel in the&#160galaxy.&#160Through a series of daring escapades deep within a dark and dangerous criminal underworld, Han Solo befriends his mighty future copilot Chewbacca and meets the notorious gambler Lando Calrissian, in a journey that will set the course of one of the&#160Star Wars&#160saga's most unlikely heroes."</blockquote><p>Join <a href="https://movieweb.com/han-solo-footage-didnt-show-alden-ehrenreich/" class="news">Han Solo</a>, Lando Calrissian, Qi'ra and Chewbacca as they set off on an all-new journey across the <em>Star Wars</em> universe. We've included all of the images here along with the trailer in case you missed the first couple of rounds it's been shared, all courtesy of Disney and <a href="http://youtu.be/dNW0B0HsvVs" target="_blank">Lucafilm</a>.</p><p><figure class="youtube-embed"><iframe width="100%" src="//www.youtube.com/embed/dNW0B0HsvVs" frameborder="0" allowfullscreen></iframe></figure></p><p><figure><img src="https://cdn.movieweb.com/img.site/PHBrZD9NWaQdFF_1_l.jpg" alt="<strong><em>Solo: A Star Wars Story</em></strong> photo 1" title="<strong><em>Solo: A Star Wars Story</em></strong> photo 1"></figure><figure><img src="https://cdn.movieweb.com/img.site/PHBeYz3NMzX0FE_1_l.jpg" alt="<strong><em>Solo: A Star Wars Story</em></strong> photo 2" title="<strong><em>Solo: A Star Wars Story</em></strong> photo 2"></figure><figure><img src="https://cdn.movieweb.com/img.site/PHJTIDaWeGtONR_1_l.jpg" alt="<strong><em>Solo: A Star Wars Story</em></strong> photo 3" title="<strong><em>Solo: A Star Wars Story</em></strong> photo 3"></figure><figure><img src="https://cdn.movieweb.com/img.site/PHNsWuqLzZgcRS_1_l.jpg" alt="<strong><em>Solo: A Star Wars Story</em></strong> photo 4" title="<strong><em>Solo: A Star Wars Story</em></strong> photo 4"></figure><figure><img src="https://cdn.movieweb.com/img.site/PHjjfjOG4oFkmn_1_l.jpg" alt="<strong><em>Solo: A Star Wars Story</em></strong> photo 5" title="<strong><em>Solo: A Star Wars Story</em></strong> photo 5"></figure><figure><img src="https://cdn.movieweb.com/img.site/PHyGwnjGkymNCz_1_l.jpg" alt="<strong><em>Solo: A Star Wars Story</em></strong> photo 6" title="<strong><em>Solo: A Star Wars Story</em></strong> photo 6"></figure></p><p><figure><img src="https://cdn.movieweb.com/img.site/PHrVl4LOm87TuA_1_l.jpg" alt="<strong><em>Solo: A Star Wars Story</em></strong> photo 1" title="<strong><em>Solo: A Star Wars Story</em></strong> photo 1"></figure><figure><img src="https://cdn.movieweb.com/img.site/PHJZSum3DygsNL_1_l.jpg" alt="<strong><em>Solo: A Star Wars Story</em></strong> photo 2" title="<strong><em>Solo: A Star Wars Story</em></strong> photo 2"></figure><figure><img src="https://cdn.movieweb.com/img.site/PH1LAiglIcvg44_1_l.jpg" alt="<strong><em>Solo: A Star Wars Story</em></strong> photo 3" title="<strong><em>Solo: A Star Wars Story</em></strong> photo 3"></figure><figure><img src="https://cdn.movieweb.com/img.site/PHb866us9Td3dh_1_l.jpg" alt="<strong><em>Solo: A Star Wars Story</em></strong> photo 4" title="<strong><em>Solo: A Star Wars Story</em></strong> photo 4"></figure><figure><img src="https://cdn.movieweb.com/img.site/PH31JHeD9JZz6b_1_l.jpg" alt="<strong><em>Solo: A Star Wars Story</em></strong> photo 5" title="<strong><em>Solo: A Star Wars Story</em></strong> photo 5"></figure><figure><img src="https://cdn.movieweb.com/img.site/PH5HvlPnBPoC96_1_l.jpg" alt="<strong><em>Solo: A Star Wars Story</em></strong> photo 6" title="<strong><em>Solo: A Star Wars Story</em></strong> photo 6"></figure></p></div><footer class="article-footer"><div class="article-tags"> Topics: <a href="https://movieweb.com/movie/solo-a-star-wars-story/">Han Solo</a>, <a href="https://movieweb.com/star-wars/">Star Wars</a></div><section class="article-followistic"><h4 class="article-followistic-title">Don't Miss A Story</h4><div id="followistic-root"></div><script type="text/javascript"> (function(m,u,s,i,c,a,l){m['FollowisticObject']=c;m[c]=m[c]||function(){(m[c].p=m[c].p||[]).push(arguments)}, a=u.createElement(s),l=u.getElementsByTagName(s)[0];a.async=1;a.src=i;l.parentNode.insertBefore(a,l)}) (window,document,'script','//static.followistic.com/widget/flw.js','followistic'); followistic('account', 'cfcad54533578d4d1c88ccf217ff7442'); followistic('guid', 'NEpqbMZJTfwrts'); </script></section><section class="article-add-comment" id="comments"><h2 class="article-add-comment-title">70 Breathtaking Han Solo Images Reveal New Star Wars Characters</h2><button type="button" class="article-add-comment-close-button" data-close="comments"><span>Close</span></button><div id="disqus_thread" class="article-add-comment-disqus"></div></section><div class="article-ad-content"><div class="article-more-subheading"> Best of the Web </div><div id="moviewebba"></div><script type="text/javascript"> (function() { function ad_block_test(e,o){if("undefined"!=typeof document.body){var t="0.1.2-dev",o=o?o:"sponsorText",n=document.createElement("DIV");n.id=o,n.style.position="absolute",n.style.left="-999px",n.appendChild(document.createTextNode("&nbsp;")),document.body.appendChild(n),setTimeout(function(){if(n){var o=0==n.clientHeight;try{}catch(d){console&&console.log&&console.log("ad-block-test error",d)}e(o,t),document.body.removeChild(n)}},175)}} ad_block_test(function(is_blocked){ var widget_id = 58942; if (is_blocked === true) { widget_id = 58945; } var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700); var rcel = document.createElement("script"); rcel.id = 'rc_' + Math.floor(Math.random() * 1000); rcel.type = 'text/javascript'; rcel.src = "https://trends.revcontent.com/serve.js.php?w="+widget_id+"&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth) +"&referer="+referer + '&is_blocked=' + is_blocked; rcel.async = true; var rcds = document.getElementById("moviewebba"); rcds.appendChild(rcel); }); })(); </script></div><section class="article-more"><h3 class="article-more-subheading">More Movie News</h3><div class="article-more-links"><section><a href="https://movieweb.com/han-solo-movie-fans-dont-like-alden-ehrenreich/"><img src="https://cdn.movieweb.com/img.news.tops/NELVyttsCNUtPT_1_c/Han-Solo-Movie-Fans-Dont-Like-Alden-Ehrenreich.jpg" alt="Fans Like Everything About First Solo Footage, Except Han Solo"><h2 class="article-more-links-title">Fans Like Everything About First Solo Footage, Except Han Solo</h4></a></section><section><a href="https://movieweb.com/solo-star-wars-story-han-extended-universe-legends-origin/"><img src="https://cdn.movieweb.com/img.news.tops/NEoI2tORBoDeso_2_c/Solo-Star-Wars-Story-Han-Extended-Universe-Legends.jpg" alt="Solo Is Bringing Back Han's Expanded Universe Origin Story"><h2 class="article-more-links-title">Solo Is Bringing Back Han's Expanded Universe Origin Story</h4></a></section><section><a href="https://movieweb.com/han-solo-movie-posters-characters-star-wars/"><img src="https://cdn.movieweb.com/img.news.tops/NELVYXvUxvWDQR_1_c/Han-Solo-Movie-Posters-Characters-Star-Wars.jpg" alt="Han Solo Character Posters Introduce Emilia Clarke as Qi'Ra"><h2 class="article-more-links-title">Han Solo Character Posters Introduce Emilia Clarke as Qi'Ra</h4></a></section><section><a href="https://movieweb.com/solo-star-wars-story-trailer/"><img src="https://cdn.movieweb.com/img.news.tops/NEislDCjUmXumj_4_c/Solo-Star-Wars-Story-Trailer.jpg" alt="Full Solo Trailer Arrives, It's Everything We Love About Star Wars"><h2 class="article-more-links-title">Full Solo Trailer Arrives, It's Everything We Love About Star Wars</h4></a></section><section><a href="https://movieweb.com/movie-trailers-super-bowl-2018/"><img src="https://cdn.movieweb.com/img.news.tops/NEJSGlzBOI7pNN_2_c/Movie-Trailers-Super-Bowl-2018.jpg" alt="Watch Every Movie Trailer from Super Bowl 52"><h2 class="article-more-links-title">Watch Every Movie Trailer from Super Bowl 52</h4></a></section><section><a href="https://movieweb.com/han-solo-footage-didnt-show-alden-ehrenreich/"><img src="https://cdn.movieweb.com/img.news.tops/NEILJWFqGr0wMN_1_c/Han-Solo-Footage-Didnt-Show-Alden-Ehrenreich.jpg" alt="Why Was Disney Afraid to Show Us Han Solo?"><h2 class="article-more-links-title">Why Was Disney Afraid to Show Us Han Solo?</h4></a></section></div></section><div class="ad ad-video"><div id="WatchrDesktopInContentUnit" data-geocountry="US" data-numads="1"><script async id="WatchrDesktopInContentUnitScript" src="//cdn.movieweb.com/assets/20170714/ads/WatchrDesktopInContentUnit.min.js" data-provider="spotx" data-channelId="154798"></script></div></div></footer></article></div><aside class="sidebar"><div class="ad"><div id='div-gpt-ad-1416204122903-4'><script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416204122903-4'); }); </script></div></div><div class="sidebar-links"><section><a href="https://movieweb.com/solo-star-wars-story-trailer/"><strong class="sidebar-link-heading">Full Solo Trailer Arrives, It's Everything We Love About Star Wars</strong><p class="sidebar-link-category">Movie News</p><figure class="sidebar-link-figure"><img src="https://cdn.movieweb.com/img.news.tops/NEislDCjUmXumj_4_c/Solo-Star-Wars-Story-Trailer.jpg" alt="Full Solo Trailer Arrives, It's Everything We Love About Star Wars"></figure></a></section><section><a href="https://movieweb.com/avengers-infinity-war-trailer-super-bowl-2018/"><strong class="sidebar-link-heading">Avengers: Infinity War Super Bowl Commercial Is Pure Marvel Insanity</strong><p class="sidebar-link-category">Movie News</p><figure class="sidebar-link-figure"><img src="https://cdn.movieweb.com/img.news.tops/NEbdlspKLMS1ej_5_c/Avengers-Infinity-War-Trailer-Super-Bowl-2018.jpg" alt="Avengers: Infinity War Super Bowl Commercial Is Pure Marvel Insanity"></figure></a></section><section><a href="https://movieweb.com/jurassic-world-2-super-bowl-commercial-2018/"><strong class="sidebar-link-heading">Jurassic World: Fallen Kingdom Trailer #2 Unleashes a Dinosaur Rampage</strong><p class="sidebar-link-category">Tv News</p><figure class="sidebar-link-figure"><img src="https://cdn.movieweb.com/img.news.tops/NEjt6GeeAcCYmo_1_c/Jurassic-World-2-Super-Bowl-Commercial-2018.jpg" alt="Jurassic World: Fallen Kingdom Trailer #2 Unleashes a Dinosaur Rampage"></figure></a></section><div class="ad"><div id='div-gpt-ad-1416204122903-2'><script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416204122903-2'); }); </script></div></div><section><a href="https://movieweb.com/han-solo-movie-super-bowl-trailer/"><strong class="sidebar-link-heading">First Solo: A Star Wars Story Footage Is Here</strong><p class="sidebar-link-category">Tv News</p><figure class="sidebar-link-figure"><img src="https://cdn.movieweb.com/img.news.tops/NED8k066Yt2pFL_2_c/Han-Solo-Movie-Super-Bowl-Trailer.jpg" alt="First Solo: A Star Wars Story Footage Is Here"></figure></a></section><section><a href="https://movieweb.com/cloverfield-paradox-trailer-netflix/"><strong class="sidebar-link-heading">The Cloverfield Paradox Trailer Surprises with Secret Origins Movie</strong><p class="sidebar-link-category">Tv News</p><figure class="sidebar-link-figure"><img src="https://cdn.movieweb.com/img.news.tops/NEwdH73Hog19yE_3_c/Cloverfield-Paradox-Trailer-Netflix.jpg" alt="The Cloverfield Paradox Trailer Surprises with Secret Origins Movie"></figure></a></section><section><a href="https://movieweb.com/cloverfield-3-paradox-netflix-streaming-release/"><strong class="sidebar-link-heading">Cloverfield 3 Premieres Tonight on Netflix After Super Bowl</strong><p class="sidebar-link-category">Movie News</p><figure class="sidebar-link-figure"><img src="https://cdn.movieweb.com/img.news.tops/NELHuNmEI936OT_2_c/Cloverfield-3-Paradox-Netflix-Streaming-Release.jpg" alt="Cloverfield 3 Premieres Tonight on Netflix After Super Bowl"></figure></a></section></div><section class="sidebar-sticky"><div class="ad"><div id='div-gpt-ad-1416204122903-3'><script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416204122903-3'); }); </script></div></div><header class="sidebar-heading"><h2>Latest Movie News</h2></header><ul class="sidebar-sticky-items"><li><a href="https://movieweb.com/yu-gi-oh-movie-rerelease-date-march-2018/" class="sidebar-sticky-link"><strong class="sidebar-sticky-link-heading">Yu-Gi-Oh! the Movie Returns to Theaters This March</strong><figure class="sidebar-sticky-link-figure"><img src="https://cdn.movieweb.com/img.news.tops/NEiLyBV6Bmhzlr_2_c/Yu-Gi-Oh-Movie-Rerelease-Date-March-2018.jpg" alt="Yu-Gi-Oh! the Movie Returns to Theaters This March"></figure></a></li><li><a href="https://movieweb.com/jumanji-2-titanic-movie-1997-box-office-record/" class="sidebar-sticky-link"><strong class="sidebar-sticky-link-heading">Jumanji 2 Ties 20-Year-Old Titanic Box Office Record</strong><figure class="sidebar-sticky-link-figure"><img src="https://cdn.movieweb.com/img.news.tops/NEf1CLr6Rx05ig_2_c/Jumanji-2-Titanic-Movie-1997-Box-Office-Record.jpg" alt="Jumanji 2 Ties 20-Year-Old Titanic Box Office Record"></figure></a></li><li><a href="https://movieweb.com/han-solo-movie-fans-dont-like-alden-ehrenreich/" class="sidebar-sticky-link"><strong class="sidebar-sticky-link-heading">Fans Like Everything About First Solo Footage, Except Han Solo</strong><figure class="sidebar-sticky-link-figure"><img src="https://cdn.movieweb.com/img.news.tops/NELVyttsCNUtPT_1_c/Han-Solo-Movie-Fans-Dont-Like-Alden-Ehrenreich.jpg" alt="Fans Like Everything About First Solo Footage, Except Han Solo"></figure></a></li></ul></section></aside></div></main><div class="ad-leaderboard ad-leaderboard-wrap"><div id='div-gpt-ad-1416204122903-0'><script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416204122903-0'); }); </script></div></div><footer class="site-footer"><div class="site-footer-social"><ul class="site-footer-social-links"><li><a href="https://movieweb.com/rss/" class="site-footer-feed"><span>Feed</span></a></li><li><a href="https://www.facebook.com/movieweb/" class="site-footer-facebook"><span>Facebook</span></a></li><li><a href="https://twitter.com/intent/follow?source=followbutton&variant=1.0&screen_name=movieweb&original_referer=https://movieweb.com/han-solo-movie-photos-new-star-wars-trailer-images/" class="site-footer-twitter"><span>Twitter</span></a></li><li><a href="https://plus.google.com/+movieweb/posts" class="site-footer-google-plus"><span>Google+</span></a></li><li><a href="https://www.youtube.com/user/movieweb?sub_confirmation=1" class="site-footer-youtube"><span>YouTube</span></a></li></ul></div><div class="site-footer-info"><ul class="site-footer-info-links"><li><a href="https://movieweb.com/about/">About</a></li><li><a href="https://movieweb.com/news/">Archive</a></li><li><a href="https://movieweb.com/privacy/">Privacy</a></li><li><a href="https://movieweb.com/terms/">Terms</a></li><li><a href="https://movieweb.com/contact/">Contact</a></li></ul><p class="site-footer-copyright"><small>&copy; Watchr Media &bullet; Cassius Network &bullet; All rights reserved</small></p></div></footer><div class="hidden"><script type='text/javascript'> googletag.cmd.push(function() { googletag.defineOutOfPageSlot('/1007926/Interstitial', 'div-gpt-ad-1416695535258-0-oop').addService(googletag.pubads()); googletag.pubads().setTargeting("type", "news"); googletag.pubads().enableSingleRequest(); googletag.enableServices(); }); </script><div id='div-gpt-ad-1416695535258-0-oop'><script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416695535258-0-oop'); }); </script></div></div><div class="hidden"><script type="text/javascript"> !function(){top.ggproducts=[1];var a,b="e06f871c",c="https://g2.gumgum.com/javascripts/ggv2.js",d=top,e="script",f=d.document,g=f.getElementsByTagName(e)[0],h=d.XMLHttpRequest||d.XDomainRequest,i=function(a){var b=f.createElement(e);b.src=a,b.async=!0,g.parentNode.insertBefore(b,g)},j=function(){d.clearTimeout(a)};return d.ggv2id=b,h?(h=new h,h.open("GET",c),h.onload=function(){j();try{(d.execScript||function(a){d.eval.call(d,a)})(h.responseText)}catch(a){}},a=d.setTimeout(function(){h.abort()},3e3),void h.send()):i(c)}(); </script><script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script></div><script type="text/javascript"> WebFontConfig = { custom: { families: [ 'Font Awesome', 'Titling Gothic Narrow Light', 'Titling Gothic Cond Light', 'Titling Gothic Cond Standard', 'Titling Gothic Cond Regular', 'Titling Gothic Comp Medium' ], urls: ['//cdn.movieweb.com/assets/5a7441216e9cc/sites/movieweb.com/fonts.min.css'] }, google: { families: ['Open Sans:300,300i,400,400i,600,600i,700,700i,800,800i', 'Titillium Web:400'] } }; (function() { var wf = document.createElement('script'); wf.src = ('https:' == document.location.protocol ? 'https' : 'http') + '://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js'; wf.type = 'text/javascript'; wf.async = 'true'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(wf, s); })(); </script><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:300,300i,400,400i,600,600i,700,700i,800,800i|Titillium+Web:400" data-norem></noscript><script> (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){ (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o), m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m) })(window,document,'script','//www.google-analytics.com/analytics.js','ga'); ga('create', 'UA-1660542-1', 'auto'); ga('set', {'dimension1':'B. Alan Orange'}); ga('set', {'contentGroup1':"Han Solo"}); ga('set', {'contentGroup2':"Star Wars"}); ga('set', {'contentGroup3':"Solo: A Star Wars Story"}); ga('set', {'contentGroup4':"Movie News"}); ga('send', 'pageview'); </script><script> var _comscore = _comscore || []; _comscore.push({ c1: "2", c2: "17091571" }); (function() { var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true; s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js"; el.parentNode.insertBefore(s, el); })(); </script><noscript><img src="https://b.scorecardresearch.com/p?c1=2&c2=17091571&cv=2.0&cj=1" alt="MovieWeb" /></noscript><script src="//cdn.movieweb.com/assets/5a7441216e9cc/sites/sites-main/js/jquery-3.2.0.min.js"></script><script src="//cdn.movieweb.com/assets/5a7441216e9cc/sites/sites-main/js/jquery.waypoints.min.js"></script><script src="//cdn.movieweb.com/assets/5a7441216e9cc/sites/sites-main/js/app.min.js"></script><script>docReady();</script><script type="text/javascript" src="//cdn.movieweb.com/assets/5a7441216e9cc/vendor/youtube-playlist-player/js/yt.min.js"></script><script type="text/javascript"> Q.youtube_playlister('movieweb'); </script><noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=4fQco1IWNa10zK" style="display:none" height="1" width="1" alt="alexa" /></noscript><script type="text/javascript"> var w_yahoo = (top == self) ? window : window.top, d_yahoo = w_yahoo.document; w_yahoo.adUnitCode = w_yahoo.adUnitCode || []; w_yahoo.adUnitCode.push("6642de07-01b7-4efb-8616-3b3ef713d44e"); w_yahoo.apiKey = "XD9B6HTTT8X4YJYSV7D7"; (function(){ var script = d_yahoo.createElement("script"); script.async = true; script.src = "https://s.yimg.com/av/yap/ga/yap.js"; d_yahoo.body.appendChild(script); })(); </script></body></html>