<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><title>Mark Hamill Hilariously Shames Porg Hater John Boyega - MovieWeb</title><meta name="description" content="Star Wars: The Last Jedi stars Mark Hamill and John Boyega have fun trolling each other over their love hate relationship with Porgs."><meta http-equiv="X-UA-Compatible" content="IE=edge"><link rel="profile" href="http://gmpg.org/xfn/11" /><link rel="publisher" href="https://plus.google.com/+movieweb/posts" /><meta property="og:locale" content="en_US" /><meta property="og:site_name" content="MovieWeb" /><meta property="fb:app_id" content="357878074202" /><meta property="fb:pages" content="46132502198" /><meta property="fb:admins" content="701427497" /><meta property="fb:admins" content="804274940" /><meta property="fb:admins" content="1295310549" /><meta name="twitter:domain" content="movieweb.com"><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://feedproxy.google.com/movieweb_news" /><meta name="robots" content="noodp" /><meta name="robots" content="noydir" /><link rel="canonical" href="https://movieweb.com/star-wars-last-jedi-porg-troll-mark-hamill-john-boyega/" /><link rel="amphtml" href="https://movieweb.com/amp/star-wars-last-jedi-porg-troll-mark-hamill-john-boyega/" /><link rel="image_src" href="https://cdn.movieweb.com/img.news.tops/NEbdZT17YGHbek_2_a/Star-Wars-Last-Jedi-Porg-Troll-Mark-Hamill.jpg"><meta name="news_keywords" content="Star Wars 8,Star Wars,Star Wars: The Last Jedi,Movie News" /><meta property="og:type" content="article" /><meta property="og:title" content="Mark Hamill Hilariously Shames Porg Hater John Boyega" /><meta property="og:url" content="https://movieweb.com/star-wars-last-jedi-porg-troll-mark-hamill-john-boyega/" /><meta property="og:description" content="Star Wars: The Last Jedi stars Mark Hamill and John Boyega have fun trolling each other over their love hate relationship with Porgs."><meta property="og:image" content="https://cdn.movieweb.com/img.news.tops/NEbdZT17YGHbek_2_a/Star-Wars-Last-Jedi-Porg-Troll-Mark-Hamill.jpg" /><meta name="twitter:title" content="Mark Hamill Hilariously Shames Porg Hater John Boyega"><meta name="twitter:description" content="Star Wars: The Last Jedi stars Mark Hamill and John Boyega have fun trolling each other over their love hate relationship with Porgs."><meta name="twitter:card" content="photo" /><meta name="twitter:image" content="https://cdn.movieweb.com/img.news.tops/NEbdZT17YGHbek_2_a/Star-Wars-Last-Jedi-Porg-Troll-Mark-Hamill.jpg" /><meta name="twitter:image:alt" content="Mark Hamill Hilariously Shames Porg Hater John Boyega" /><meta name="twitter:url" content="https://movieweb.com/star-wars-last-jedi-porg-troll-mark-hamill-john-boyega/"><meta name="twitter:site" content="@movieweb" /><meta property="article:publisher" content="https://www.facebook.com/movieweb/" /><meta property="article:published_time" content="2017-12-07T10:38:03-08:00" /><meta property="article:modified_time" content="2017-12-07T10:38:04-08:00" /><meta property="article:section" content="Movie News" /><meta property="article:tag" content="Star Wars 8" /><meta property="article:tag" content="Star Wars" /><meta property="article:tag" content="Star Wars: The Last Jedi" /><meta property="article:tag" content="Movie News" /><link rel="author" href="https://plus.google.com/101130247270497925158"><link rel="dns-prefetch" href="//cdn.movieweb.com"><link rel="dns-prefetch" href="//www.google-analytics.com"><link rel="dns-prefetch" href="https://ajax.googleapis.com"><link rel="dns-prefetch" href="//fonts.typonine.com/"><link rel="dns-prefetch" href="//c.amazon-adsystem.com"><link rel="dns-prefetch" href="//www.googletagservices.com"><link rel="dns-prefetch" href="//ap.lijit.com"><link rel="dns-prefetch" href="//gslbeacon.lijit.com"><link rel="manifest" href="/manifest.json"><meta name="mobile-web-app-capable" content="yes"><meta name="application-name" content="MovieWeb"><meta name="msapplication-TileColor" content="#cc0000"><meta name="msapplication-TileImage" content="//cdn.movieweb.com/assets/5a1da0b188178/sites/movieweb.com/icons/mstile-144x144.png"><meta name="theme-color" content="#ffffff"><link rel="apple-touch-icon" sizes="144x144" href="//cdn.movieweb.com/assets/5a1da0b188178/sites/movieweb.com/icons/apple-touch-icon-144x144.png" /><link rel="apple-touch-icon" sizes="114x114" href="//cdn.movieweb.com/assets/5a1da0b188178/sites/movieweb.com/icons/apple-touch-icon-114x114.png" /><link rel="apple-touch-icon" sizes="72x72" href="//cdn.movieweb.com/assets/5a1da0b188178/sites/movieweb.com/icons/apple-touch-icon-72x72.png" /><link rel="apple-touch-icon" sizes="57x57" href="//cdn.movieweb.com/assets/5a1da0b188178/sites/movieweb.com/icons/apple-touch-icon-57x57.png" /><link rel="apple-touch-icon" href="//cdn.movieweb.com/assets/5a1da0b188178/sites/movieweb.com/icons/apple-touch-icon-57x57.png" /><link rel="shortcut icon" href="//cdn.movieweb.com/assets/5a1da0b188178/sites/movieweb.com/icons/favicon.ico" type="image/x-icon"><link rel="icon" href="//cdn.movieweb.com/assets/5a1da0b188178/sites/movieweb.com/icons/favicon.ico" type="image/x-icon"><script> var site_domain = 'movieweb.com'; var device_type = 'desktop'; var news_type = 'article'; </script><script>(function(a,b,c,d,e){e=a.createElement(b);a=a.getElementsByTagName(b)[0];e.async=1;e.src=c;a.parentNode.insertBefore(e,a)})(document,'script','//separatesilver.com/0cbf0251db822e69a4eb820faba60d9d15182d6431a69fa1232f810a7147d0a820c3ec420e7a9df509903d130b95744b0749dc31a93b145d25fadd58491b');</script><script src="//cdn.movieweb.com/assets/5a1da0b188178/sites/movieweb.com/ads.hb.v5.min.js"></script><script type='text/javascript'> googletag.cmd.push(function() { googletag.pubads().setTargeting("type", "news"); var banner_leader_728x90 = googletag.defineSlot('/1007926/MW_ROS_ATF_728_320_Leader', [728, 90], 'div-gpt-ad-1416204122903-7').addService(googletag.pubads()); var banner_leader_combined_mapping = googletag.sizeMapping(). addSize([1400, 250], [[1000,200], [970, 250], [970, 90], [728, 90], [320, 50]]). addSize([1170, 250], [[728, 90], [320, 50]]). addSize([1024, 250], [320, 50]). addSize([728, 250], [[728, 90], [320, 50]]). addSize([0, 0], [320,50]).build(); var banner_leader_combined = googletag.defineSlot('/1007926/MW_ROS_ATF_Combined_Leader', [[320, 50], [728, 90], [970, 90], [970, 250], [1000,200]], 'div-gpt-ad-1416204122903-0'). defineSizeMapping(banner_leader_combined_mapping). addService(googletag.pubads()); googletag.pubads().setTargeting("has_video", "no"); var banner_video_news = googletag.defineSlot('/1007926/MW_News_Video_Unit', [[430, 343], [336, 280], [300, 250]], 'div-gpt-ad-1416204363531-0').addService(googletag.pubads()); var banner_ros_square_right1 = googletag.defineSlot('/1007926/MW_ROS_Right_ATF_300x250', [[300, 250], [300, 600], [300, 1050]], 'div-gpt-ad-1416204122903-4').addService(googletag.pubads()); var banner_ros_square_right2 = googletag.defineSlot('/1007926/MW_ROS_MID1_300', [[300, 250], [300, 600], [300, 1050]], 'div-gpt-ad-1416204122903-2').addService(googletag.pubads()); var banner_ros_square_right3 = googletag.defineSlot('/1007926/MW_ROS_MID2_300', [[300, 250], [300, 600], [300, 1050]], 'div-gpt-ad-1416204122903-3').addService(googletag.pubads()); var banner_ros_bottom = googletag.defineSlot('/1007926/MW_ROS_Bottom_728x90', [728, 90], 'div-gpt-ad-1416204122903-1').addService(googletag.pubads()); pbjs.que.push(function() { pbjs.setTargetingForGPTAsync() }); googletag.pubads().setTargeting("page", [window.location.pathname.replace("/", "")]); googletag.pubads().setCentering(true); googletag.pubads().collapseEmptyDivs(true); googletag.pubads().enableSingleRequest(); googletag.enableServices(); }); </script><script type="text/javascript"> _atrk_opts = { atrk_acct:"4fQco1IWNa10zK", domain:"movieweb.com",dynamic: true}; (function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })(); </script><script type="application/ld+json"> { "@context" : "http://schema.org", "@type" : "Organization", "name" : "MovieWeb", "url" : "https://movieweb.com", "logo": "https://cdn.movieweb.com/assets/5a1da0b188178/sites/movieweb.com/logo-amp.png" } </script><link rel="stylesheet" href="//cdn.movieweb.com/assets/5a1da0b188178/sites/movieweb.com/main.min.css?5a1da0b188178"><!--[if lte IE 9]><script src="//cdn.movieweb.com/assets/5a1da0b188178/sites/sites-main/js/html5shiv.min.js"></script><script src="//cdn.movieweb.com/assets/5a1da0b188178/sites/sites-main/js/rem.min.js"></script><link rel="stylesheet" href="//cdn.movieweb.com/assets/5a1da0b188178/sites/sites-main/css/ie8-9.min.css"><![endif]--></head><body><header class="site-header"><div class="inner"><div class="site-title"><a href="https://movieweb.com" class="site-logo">MovieWeb</a></div><button class="site-nav-button"><span>Menu</span></button><nav class="site-nav" itemscope itemtype="http://schema.org/SiteNavigationElement"><div class="site-nav-social"><ul class="site-nav-social-items"><li class="site-nav-social-facebook"><a href="https://www.facebook.com/movieweb/" target="_blank"><span>Facebook</span></a></li><li class="site-nav-social-twitter"><a href="https://twitter.com/intent/follow?source=followbutton&variant=1.0&screen_name=movieweb&original_referer=https://movieweb.com/star-wars-last-jedi-porg-troll-mark-hamill-john-boyega/" target="_blank"><span>Twitter</span></a></li><li class="site-nav-social-google-plus"><a href="https://plus.google.com/+movieweb/posts" target="_blank"><span>Google+</span></a></li><li class="site-nav-social-youtube"><a href="https://www.youtube.com/user/movieweb?sub_confirmation=1" target="_blank"><span>YouTube</span></a></li><li class="site-nav-social-feed"><a href="https://movieweb.com/rss/"><span>Feed</span></a></li></ul></div><div class="site-nav-content"><ul class="site-nav-content-items"><li itemprop="name"><a href="https://movieweb.com/movie-news/" itemprop="url">Movie News</a></li><li itemprop="name"><a href="https://movieweb.com/new-movies/" itemprop="url">New Movies</a></li><li itemprop="name"><a href="https://movieweb.com/movie-trailers/" itemprop="url">Movie Trailers</a></li><li itemprop="name"><a href="https://movieweb.com/movie-reviews/" itemprop="url">Movie Reviews</a></li><li itemprop="name"><a href="https://movieweb.com/tv-news/" itemprop="url">TV News</a></li><li itemprop="name"><a href="https://movieweb.com/superheroes/" itemprop="url">Superheroes</a></li></ul></div></nav><div class="current-article-header"><div class="current-article-site-title"><img src="https://cdn.movieweb.com/assets/1/sites/movieweb.com/logo-small.png" alt="MovieWeb"></div><div class="current-article-overview"><p class="current-article-title">Mark Hamill Hilariously Shames Porg Hater John Boyega</p></div><ul class="current-article-actions"><li><button class="current-article-button current-article-button-facebook facebook"><span class="current-article-button-facebook-label-share">Share</span></button></li><li><button class="current-article-button current-article-button-comments" data-toggle="comments"><span class="current-article-button-comments-label-comments">Comments</span><span class="current-article-button-comments-label-count"></span></button></li></ul></div><div class="site-search"><button type="button" class="site-search-open-button" data-toggle="site-search-form"><span>Search</span></button><form id="site-search-form" class="site-search-form" data-toggle-focus="site-search-input" action="/search/"><input type="hidden" name="cx" value="002976262196911623014:ycta8t2-kmy"><input type="hidden" name="cof" value="FORID:9"><input type="hidden" name="ie" value="UTF-8"><button type="button" class="site-search-close-button" data-close="site-search-form"><span>Close</span></button><input id="site-search-input" type="search" class="site-search-input" name="q" placeholder="Find Movies &amp; TV Shows" autocomplete="off"><button type="submit" class="site-search-submit-button"><span>Search</span></button></form></div></div></header><main class="main page-articles"><div class="inner"><div class="article-list"><script type="application/ld+json"> { "@context": "http://schema.org", "@type": "Article", "url": "https://movieweb.com/star-wars-last-jedi-porg-troll-mark-hamill-john-boyega/", "mainEntityOfPage": "https://movieweb.com/star-wars-last-jedi-porg-troll-mark-hamill-john-boyega/", "dateCreated": "2017-12-07T10:38:03-08:00", "datePublished": "2017-12-07T10:38:03-08:00", "dateModified": "2017-12-07T10:38:04-08:00", "headline": "Mark Hamill Hilariously Shames Porg Hater John Boyega", "description": "Star Wars: The Last Jedi stars Mark Hamill and John Boyega have fun trolling each other over their love hate relationship with Porgs.", "keywords": [ "Star Wars 8","Star Wars","Star Wars: The Last Jedi" ], "image": { "@type": "ImageObject", "url": "https://cdn.movieweb.com/img.news.tops/NEbdZT17YGHbek_2_a/Star-Wars-Last-Jedi-Porg-Troll-Mark-Hamill.jpg", "height": 395, "width": 750 }, "author": { "@type": "Person", "name": "Kevin Burwick", "url": "https://movieweb.com/contributors/kevin-burwick/" }, "publisher": { "@type": "Organization", "name": "MovieWeb", "logo": { "@type": "ImageObject", "url": "https://cdn.movieweb.com/assets/5a1da0b188178/sites/movieweb.com/logo-amp.png", "width": 293, "height": 60 } }, "articleBody": "Master troll Mark Hamill is trolling members of the Star Wars: The Last Jedi cast about their lack of 'Porg adoration.' John Boyega and Hamill have a playful social media relationship where they call each other father and son, but it appears that Hamill's 'son' has taken a hard stance against the Porgs, even insinuating that he has started to eat them, but Hamill had the last word, shutting Boyega down with an outstanding meme. Respect your elders comes to mind, but you'll just have to check it out and see for yourself. 'I should warned you about the potential hazards of #Porg soup, son. #InSpaceNoOneCanHearYouSqueeeee.' John Boyega has had a lot of negative things to say about the Porgs during the promotional tour for The Last Jedi. The actor has revealed that he was initially horrified by the sight of them, much like many Star Wars fans, but the nothing could prepare Mark Hamill for what Boyega had to say while the cast was on the Jimmy Kimmel Live show. When asked by Kimmel how the cast felt about the Porgs, John Boyega nonchalantly said that he 'hated them,' which prompted Mark Hamill to have a chat with his 'son' over social media about the joys of Porgs. Mark Hamill started the Porg conversation by telling John Boyega that he did not appreciate his opinion of the weird puffin creatures. Hamill went on to preach about the finer points of Porgs. He had this to say. 'I find you lack of #PorgAdoration disturbing, son. I raised you better than that! You usually are so enlightened &amp; porgressive. They are not aggressive or a threat! (L) They are a positive inspiration! (R)' John Boyega decided that he didn't want to hear any more about these Porgs and responded with, 'This Porg soup is delicious...' This is where Hamill, the master Star Wars troll stepped into action, responding with a meme featuring a Porg as a Chestburster ripping out of John Hurt's stomach in Alien. Though, Disney must have felt this was a little too graphic as it was later removed from Hamill's Twitter feed. John Boyega is not alone on his hatred of the Porgs. Many Star Wars fans are worried that they're going to be the Ewoks of The Last Jedi, or even worse, the Jar Jar Binks of the new trilogy, which nobody wants. The latest TV spots have not been helping the cause for the Porgs because they really are starting to look like some easy way for easy laughs and slapstick comedy, which is apparently not allowed in the Star Wars universe. Regardless, they're here to stay and they don't seem to be going anywhere. If John Boyega really got sick from eating the Porg soup, he should've followed our complete recipe on how to properly cook a Porg for the holidays. We've been eating them up here for weeks and nobody has gotten seriously ill, save for maybe some unwanted gas, but definitely no issues with Chestbursters. All kidding aside, The Last Jedi is almost upon us and the suspense is really starting to get to people, leading to more speculation and excitement. The Last Jedi hits theaters officially on December 15th, but in the meantime, you can check out some expert level trolling of John Boyega courtesy of Mark Hamill's Twitter account below. .@JohnBoyega I find you lack of #PorgAdoration disturbing, son. I raised you better than that! You usually are so enlightened &amp; porgressive.They are not aggressive or a threat! (L)They are a positive inspiration! (R)#PorgsArePrecious #DontBeAPorgPessimist pic.twitter.com/EDpFVBlV5u&mdash; @HamillHimself (@HamillHimself) December 5, 2017 This porg soup is delicious..... https://t.co/7XM2PGkqsj&mdash; John Boyega (@JohnBoyega) December 6, 2017" } </script><article class="article"><header class="article-header" data-newsid="NEbdZT17YGHbek" data-loadmore="true" data-newscategory="Announcement" data-title="Mark Hamill Hilariously Shames Porg Hater John Boyega" data-image="https%3A%2F%2Fcdn.movieweb.com%2Fimg.news.tops%2FNEbdZT17YGHbek_2_a%2FStar-Wars-Last-Jedi-Porg-Troll-Mark-Hamill.jpg" data-url="https%3A%2F%2Fmovieweb.com%2Fstar-wars-last-jedi-porg-troll-mark-hamill-john-boyega%2F" data-shares="30" data-fbappid="357878074202"><figure class="article-header-figure"><img src="https://cdn.movieweb.com/img.news.tops/NEbdZT17YGHbek_2_b/Star-Wars-Last-Jedi-Porg-Troll-Mark-Hamill.jpg" alt="Star Wars: The Last Jedi stars Mark Hamill and John Boyega have fun trolling each other over their love hate relationship with Porgs."></figure><div class="article-header-info"><h1 class="article-header-title">Mark Hamill Hilariously Shames Porg Hater John Boyega</h1><div class="article-header-credits"><p class="article-header-author"><a href="https://movieweb.com/contributors/kevin-burwick/">Kevin Burwick</a></p><p class="article-header-date"><time datetime="2017-12-07T10:38:03-08:00">12.07.2017</time></p></div></div><ul class="article-header-social"><li class="article-header-social-shares"><span class="article-header-social-shares-count">30</span><span class="article-header-social-shares-label">shares</span></li><li class="article-header-social-item article-header-facebook facebook"><a href="#"><span>Facebook</span></a></li><li class="article-header-social-item article-header-twitter twitter"><a href="#"><span>Twitter</span></a></li><li class="article-header-social-item article-header-google-plus google-plus"><a href="#"><span>Google+</span></a></li><li class="article-header-social-item article-header-email email"><a href="#"><span>Email</span></a></li><li class="article-header-social-item article-header-comment comment"><a href="#" data-toggle="comments"><span>Comment</span></a></li></ul></header><div class="ad-leaderboard-news ad-leaderboard-wrap"><div id='div-gpt-ad-1416204122903-7' style='height:90px; width:728px;'><script> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416204122903-7'); }); </script></div></div><div class="article-body"><p>Master troll <a href="https://movieweb.com/person/mark-hamill/" class="person">Mark Hamill</a> is trolling members of the <a href="https://movieweb.com/movie/star-wars-the-last-jedi/" class="movie"><strong><em>Star Wars: The Last Jedi</em></strong></a> cast about their lack of "Porg adoration." John Boyega and Hamill have a playful social media relationship where they call each other father and son, but it appears that Hamill's "son" has taken a hard stance against the Porgs, even insinuating that he has started to eat them, but Hamill had the last word, shutting Boyega down with an outstanding meme. Respect your elders comes to mind, but you'll just have to check it out and see for yourself.</p><blockquote class="quote">"I should warned you about the potential hazards of #Porg soup, son. #InSpaceNoOneCanHearYouSqueeeee."</blockquote><p><a href="https://movieweb.com/person/john-boyega/" class="person">John Boyega</a> has had a lot of negative things to say about the Porgs during the promotional tour for <em>The Last Jedi</em>. The actor has revealed that he was initially horrified by the sight of them, much like many <em>Star Wars</em> fans, but the nothing could prepare Mark Hamill for what Boyega had to say while the cast was on the <em>Jimmy Kimmel Live</em> show. When asked by Kimmel how the cast felt about the Porgs, John Boyega nonchalantly said that he "hated them," which prompted Mark Hamill to have a chat with his "son" over social media about the <a href="https://movieweb.com/chewbacca-actor-punching-porg-star-wars-last-jedi/" class="news">joys of Porgs</a>.</p><div class="ad ad-news"><script type="text/javascript"> google_ad_client = "ca-pub-6711743007492678"; google_ad_slot = "Publishr/PR8w1sw4pTTzbf"; google_ad_width = 300; google_ad_height = 250; </script><script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js"></script></div><p>Mark Hamill started the Porg conversation by telling John Boyega that he did not appreciate his opinion of the weird puffin creatures. Hamill went on to preach about the finer points of Porgs. He had this to say.</p><blockquote class="quote">"I find you lack of #PorgAdoration disturbing, son. I raised you better than that! You usually are so enlightened &amp; porgressive. They are not aggressive or a threat! (L) They are a positive inspiration! (R)"</blockquote><p>John Boyega decided that he didn't want to hear any more about these <a href="https://movieweb.com/star-wars-last-jedi-posters-droids-weapons-ships/" class="news">Porgs</a> and responded with, "This Porg soup is delicious..." This is where Hamill, the master <em>Star Wars</em> troll stepped into action, responding with a meme featuring a Porg as a Chestburster ripping out of John Hurt's stomach in <em>Alien</em>. Though, Disney must have felt this was a little too graphic as it was later removed from Hamill's Twitter feed.</p><p>John Boyega is not alone on his <a href="https://movieweb.com/star-wars-last-jedi-tv-trailer-flying-porg-joke/" class="news">hatred of the Porgs</a>. Many <em>Star Wars</em> fans are worried that they're going to be the Ewoks of <em>The Last Jedi</em>, or even worse, the Jar Jar Binks of the new trilogy, which nobody wants. The latest TV spots have not been helping the cause for the Porgs because they really are starting to look like some easy way for easy laughs and slapstick comedy, which is apparently not allowed in the <em>Star Wars</em> universe. Regardless, they're here to stay and they don't seem to be going anywhere.</p><p>If John Boyega really got sick from eating the Porg soup, he should've followed our complete recipe on how to properly <a href="https://movieweb.com/porg-recipe-star-wars-last-jedi-thanksgiving-christmas/" class="news">cook a Porg for the holidays</a>. We've been eating them up here for weeks and nobody has gotten seriously ill, save for maybe some unwanted gas, but definitely no issues with Chestbursters. All kidding aside, <em>The Last Jedi</em> is almost upon us and the suspense is really starting to get to people, leading to more speculation and excitement. <em>The Last Jedi</em> hits theaters officially on December 15th, but in the meantime, you can check out some expert level trolling of John Boyega courtesy of <a href="http://twitter.com/HamillHimself/status/938545668896915456" target="_blank">Mark Hamill's Twitter</a> account below.</p><blockquote class="twitter-tweet" align="center" data-width="500" data-lang="en"><p lang="en" dir="ltr">.<a href="https://twitter.com/JohnBoyega?ref_src=twsrc%5Etfw">@JohnBoyega</a> I find you lack of <a href="https://twitter.com/hashtag/PorgAdoration?src=hash&amp;ref_src=twsrc%5Etfw">#PorgAdoration</a> disturbing, son. I raised you better than that! You usually are so enlightened &amp; porgressive.<br>They are not aggressive or a threat! (L)<br>They are a positive inspiration! (R)<a href="https://twitter.com/hashtag/PorgsArePrecious?src=hash&amp;ref_src=twsrc%5Etfw">#PorgsArePrecious</a><a href="https://twitter.com/hashtag/DontBeAPorgPessimist?src=hash&amp;ref_src=twsrc%5Etfw">#DontBeAPorgPessimist</a><a href="https://t.co/EDpFVBlV5u">pic.twitter.com/EDpFVBlV5u</a></p>&mdash; @HamillHimself (@HamillHimself) <a href="https://twitter.com/HamillHimself/status/938178509926572032?ref_src=twsrc%5Etfw">December 5, 2017</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><blockquote class="twitter-tweet" align="center" data-width="500" data-lang="en"><p lang="en" dir="ltr">This porg soup is delicious..... <a href="https://t.co/7XM2PGkqsj">https://t.co/7XM2PGkqsj</a></p>&mdash; John Boyega (@JohnBoyega) <a href="https://twitter.com/JohnBoyega/status/938455220182507520?ref_src=twsrc%5Etfw">December 6, 2017</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><p><figure><img src="https://cdn.movieweb.com/img.news/NEbdZT17YGHbek_1_1.jpg" width="300" height="158" alt="Star Wars Alien Porg Chestburster" title="Star Wars Alien Porg Chestburster" class="center-block"></figure></p></div><footer class="article-footer"><div class="article-tags"> Topics: <a href="https://movieweb.com/movie/star-wars-the-last-jedi/">Star Wars 8</a>, <a href="https://movieweb.com/star-wars/">Star Wars</a></div><section class="article-followistic"><h4 class="article-followistic-title">Don't Miss A Story</h4><div id="followistic-root"></div><script type="text/javascript"> (function(m,u,s,i,c,a,l){m['FollowisticObject']=c;m[c]=m[c]||function(){(m[c].p=m[c].p||[]).push(arguments)}, a=u.createElement(s),l=u.getElementsByTagName(s)[0];a.async=1;a.src=i;l.parentNode.insertBefore(a,l)}) (window,document,'script','//static.followistic.com/widget/flw.js','followistic'); followistic('account', 'cfcad54533578d4d1c88ccf217ff7442'); followistic('guid', 'NEbdZT17YGHbek'); </script></section><section class="article-add-comment" id="comments"><h2 class="article-add-comment-title">Mark Hamill Hilariously Shames Porg Hater John Boyega</h2><button type="button" class="article-add-comment-close-button" data-close="comments"><span>Close</span></button><div id="disqus_thread" class="article-add-comment-disqus"></div></section><div class="ad-leaderboard ad-leaderboard-wrap"><div id='div-gpt-ad-1416204122903-0'><script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416204122903-0'); }); </script></div></div><div class="article-ad-content"><div class="article-more-subheading"> Best of the Web </div><div id="moviewebba"></div><script type="text/javascript"> (function() { function ad_block_test(e,o){if("undefined"!=typeof document.body){var t="0.1.2-dev",o=o?o:"sponsorText",n=document.createElement("DIV");n.id=o,n.style.position="absolute",n.style.left="-999px",n.appendChild(document.createTextNode("&nbsp;")),document.body.appendChild(n),setTimeout(function(){if(n){var o=0==n.clientHeight;try{}catch(d){console&&console.log&&console.log("ad-block-test error",d)}e(o,t),document.body.removeChild(n)}},175)}} ad_block_test(function(is_blocked){ var widget_id = 58942; if (is_blocked === true) { widget_id = 58945; } var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700); var rcel = document.createElement("script"); rcel.id = 'rc_' + Math.floor(Math.random() * 1000); rcel.type = 'text/javascript'; rcel.src = "https://trends.revcontent.com/serve.js.php?w="+widget_id+"&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth) +"&referer="+referer + '&is_blocked=' + is_blocked; rcel.async = true; var rcds = document.getElementById("moviewebba"); rcds.appendChild(rcel); }); })(); </script></div><section class="article-more"><h3 class="article-more-subheading">More Movie News</h3><div class="article-more-links"><section><a href="https://movieweb.com/star-wars-last-jedi-carrie-fisher-dog-gary-alien/"><img src="https://cdn.movieweb.com/img.news.tops/NELqSnZkiE5MPO_1_c/Star-Wars-Last-Jedi-Carrie-Fisher-Dog-Gary.jpg" alt="Carrie Fisher's Dog Was Turned Into an Alien in The Last Jedi"><h2 class="article-more-links-title">Carrie Fisher's Dog Was Turned Into an Alien in The Last Jedi</h4></a></section><section><a href="https://movieweb.com/star-wars-last-jedi-new-weapon-lightsaber-hue/"><img src="https://cdn.movieweb.com/img.news.tops/NEgqRrzxlZyKkk_2_c/Star-Wars-Last-Jedi-New-Weapon-Lightsaber-Hue.jpg" alt="Last Jedi Director Teases a Mysterious Twist for an Iconic Weapon"><h2 class="article-more-links-title">Last Jedi Director Teases a Mysterious Twist for an Iconic Weapon</h4></a></section><section><a href="https://movieweb.com/star-wars-last-jedi-first-cut-runtime-deleted-scenes-blu-ray/"><img src="https://cdn.movieweb.com/img.news.tops/NEKcWiEkRcfHOK_1_c/Star-Wars-Last-Jedi-First-Cut-Runtime-Deleted.jpg" alt="Last Jedi First Cut Was Over 3 Hours Long"><h2 class="article-more-links-title">Last Jedi First Cut Was Over 3 Hours Long</h4></a></section><section><a href="https://movieweb.com/star-wars-last-jedi-daisy-ridley-clarifies-franchise-future-comments/"><img src="https://cdn.movieweb.com/img.news.tops/NEvrZl8GU7Ttzx_2_c/Star-Wars-Last-Jedi-Daisy-Ridley-Clarifies-Franchise.jpg" alt="Daisy Ridley's Rey May Return in a Future Star Wars Movie After All"><h2 class="article-more-links-title">Daisy Ridley's Rey May Return in a Future Star Wars Movie After All</h4></a></section><section><a href="https://movieweb.com/star-wars-last-jedi-female-cast-carrie-fisher-tribute/"><img src="https://cdn.movieweb.com/img.news.tops/NEqUNQIB04w2tz_1_c/Star-Wars-Last-Jedi-Female-Cast-Carrie-Fisher.jpg" alt="The Women of Last Jedi Pay Tribute to Carrie Fisher"><h2 class="article-more-links-title">The Women of Last Jedi Pay Tribute to Carrie Fisher</h4></a></section><section><a href="https://movieweb.com/star-wars-last-jedi-chinese-trailer-fathiers/"><img src="https://cdn.movieweb.com/img.news.tops/NE9Lu9CvcL4zce_1_c/Star-Wars-Last-Jedi-Chinese-Trailer-Fathiers.jpg" alt="Space Horses Run Wild in New Last Jedi Chinese Trailer"><h2 class="article-more-links-title">Space Horses Run Wild in New Last Jedi Chinese Trailer</h4></a></section></div></section><div class="ad ad-video"><div id="WatchrDesktopInContentUnit" data-geocountry="US" data-numads="1"><script async id="WatchrDesktopInContentUnitScript" src="//cdn.movieweb.com/assets/20170714/ads/WatchrDesktopInContentUnit.min.js" data-provider="spotx" data-channelId="154798"></script></div></div></footer></article></div><aside class="sidebar"><div class="ad"><div id='div-gpt-ad-1416204122903-4'><script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416204122903-4'); }); </script></div></div><div class="sidebar-links"><section><a href="https://movieweb.com/disney-fox-deal-close-x-men-returning-to-marvel-studios/"><strong class="sidebar-link-heading">Disney and Fox Close in on Deal, Will X-Men Join the MCU Next Week?</strong><p class="sidebar-link-category">Movie News</p><figure class="sidebar-link-figure"><img src="https://cdn.movieweb.com/img.news.tops/NE2aWGsUrWx062_1_c/Disney-Fox-Deal-Close-X-Men-Returning-To.jpg" alt="Disney and Fox Close in on Deal, Will X-Men Join the MCU Next Week?"></figure></a></section><section><a href="https://movieweb.com/star-wars-movie-tommy-wiseau-wants-to-direct/"><strong class="sidebar-link-heading">The Room's Tommy Wiseau Wants to Make a Star Wars Movie</strong><p class="sidebar-link-category">Movie News</p><figure class="sidebar-link-figure"><img src="https://cdn.movieweb.com/img.news.tops/NEKSx6xU7alROK_1_c/Star-Wars-Movie-Tommy-Wiseau-Wants-To-Direct.jpg" alt="The Room's Tommy Wiseau Wants to Make a Star Wars Movie"></figure></a></section><section><a href="https://movieweb.com/detective-pikachu-movie-cast-ryan-reynolds/"><strong class="sidebar-link-heading">Ryan Reynolds Is Detective Pikachu in Live-Action Pokemon Movie</strong><p class="sidebar-link-category">Movie News</p><figure class="sidebar-link-figure"><img src="https://cdn.movieweb.com/img.news.tops/NEpgLNUKjcbZts_2_c/Detective-Pikachu-Movie-Cast-Ryan-Reynolds.jpg" alt="Ryan Reynolds Is Detective Pikachu in Live-Action Pokemon Movie"></figure></a></section><div class="ad"><div id='div-gpt-ad-1416204122903-2'><script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416204122903-2'); }); </script></div></div><section><a href="https://movieweb.com/jurassic-world-fallen-kingdom-jeff-goldblum-ian-malcolm-video/"><strong class="sidebar-link-heading">First Look at Jeff Goldblum as Dr. Ian Malcolm in Jurassic World 2</strong><p class="sidebar-link-category">Movie News</p><figure class="sidebar-link-figure"><img src="https://cdn.movieweb.com/img.news.tops/NEyf0murqZ5GBD_1_c/Jurassic-World-Fallen-Kingdom-Jeff-Goldblum-Ian-Malcolm.jpg" alt="First Look at Jeff Goldblum as Dr. Ian Malcolm in Jurassic World 2"></figure></a></section><section><a href="https://movieweb.com/jurassic-world-fallen-kingdom-new-dinosaur-photo/"><strong class="sidebar-link-heading">Baryonyx Attacks in Best Look Yet at New Jurassic World 2 Dinosaur</strong><p class="sidebar-link-category">Movie News</p><figure class="sidebar-link-figure"><img src="https://cdn.movieweb.com/img.news.tops/NE6EQ5SQYw4ua8_1_c/Jurassic-World-Fallen-Kingdom-New-Dinosaur-Photo.jpg" alt="Baryonyx Attacks in Best Look Yet at New Jurassic World 2 Dinosaur"></figure></a></section><section><a href="https://movieweb.com/corey-feldman-1993-audio-testimony-hollywood-pedophile-names/"><strong class="sidebar-link-heading">Feldman's 1993 Audio Naming Alleged Hollywood Pedophiles Has Been Found</strong><p class="sidebar-link-category">Movie News</p><figure class="sidebar-link-figure"><img src="https://cdn.movieweb.com/img.news.tops/NEtef6toN50BvC_1_c/Corey-Feldman-1993-Audio-Testimony-Hollywood-Pedophile-Names.jpg" alt="Feldman's 1993 Audio Naming Alleged Hollywood Pedophiles Has Been Found"></figure></a></section></div><section class="sidebar-sticky"><div class="ad"><div id='div-gpt-ad-1416204122903-3'><script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416204122903-3'); }); </script></div></div><header class="sidebar-heading"><h2>Latest Movie News</h2></header><ul class="sidebar-sticky-items"><li><a href="https://movieweb.com/little-mermaid-disney-live-action-remake-director-rob-marshall/" class="sidebar-sticky-link"><strong class="sidebar-sticky-link-heading">Disney's Little Mermaid Remake Targets Mary Poppins 2 Director</strong><figure class="sidebar-sticky-link-figure"><img src="https://cdn.movieweb.com/img.news.tops/NEnNtVEqYs8drp_1_c/Little-Mermaid-Disney-Live-Action-Remake-Director-Rob.jpg" alt="Disney's Little Mermaid Remake Targets Mary Poppins 2 Director"></figure></a></li><li><a href="https://movieweb.com/deadpool-mickey-mouse-disney-fox-deal-ryan-reynolds/" class="sidebar-sticky-link"><strong class="sidebar-sticky-link-heading">Ryan Reynolds Is Ready for a Deadpool and Mickey Mouse Team-Up</strong><figure class="sidebar-sticky-link-figure"><img src="https://cdn.movieweb.com/img.news.tops/NEHt0034IFPQKM_1_c/Deadpool-Mickey-Mouse-Disney-Fox-Deal-Ryan-Reynolds.jpg" alt="Ryan Reynolds Is Ready for a Deadpool and Mickey Mouse Team-Up"></figure></a></li></ul></section></aside></div></main><div class="ad"><div id='div-gpt-ad-1416204122903-1'><script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416204122903-1'); }); </script></div></div><footer class="site-footer"><div class="site-footer-social"><ul class="site-footer-social-links"><li><a href="https://movieweb.com/rss/" class="site-footer-feed"><span>Feed</span></a></li><li><a href="https://www.facebook.com/movieweb/" class="site-footer-facebook"><span>Facebook</span></a></li><li><a href="https://twitter.com/intent/follow?source=followbutton&variant=1.0&screen_name=movieweb&original_referer=https://movieweb.com/star-wars-last-jedi-porg-troll-mark-hamill-john-boyega/" class="site-footer-twitter"><span>Twitter</span></a></li><li><a href="https://plus.google.com/+movieweb/posts" class="site-footer-google-plus"><span>Google+</span></a></li><li><a href="https://www.youtube.com/user/movieweb?sub_confirmation=1" class="site-footer-youtube"><span>YouTube</span></a></li></ul></div><div class="site-footer-info"><ul class="site-footer-info-links"><li><a href="https://movieweb.com/about/">About</a></li><li><a href="https://movieweb.com/news/">Archive</a></li><li><a href="https://movieweb.com/privacy/">Privacy</a></li><li><a href="https://movieweb.com/terms/">Terms</a></li><li><a href="https://movieweb.com/contact/">Contact</a></li></ul><p class="site-footer-copyright"><small>&copy; Watchr Media &bullet; Cassius Network &bullet; All rights reserved</small></p></div></footer><div class="hidden"><script type='text/javascript'> googletag.cmd.push(function() { googletag.defineOutOfPageSlot('/1007926/Interstitial', 'div-gpt-ad-1416695535258-0-oop').addService(googletag.pubads()); googletag.pubads().setTargeting("type", "news"); googletag.pubads().enableSingleRequest(); googletag.enableServices(); }); </script><div id='div-gpt-ad-1416695535258-0-oop'><script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1416695535258-0-oop'); }); </script></div></div><div class="hidden"><script type="text/javascript"> !function(){top.ggproducts=[1];var a,b="e06f871c",c="https://g2.gumgum.com/javascripts/ggv2.js",d=top,e="script",f=d.document,g=f.getElementsByTagName(e)[0],h=d.XMLHttpRequest||d.XDomainRequest,i=function(a){var b=f.createElement(e);b.src=a,b.async=!0,g.parentNode.insertBefore(b,g)},j=function(){d.clearTimeout(a)};return d.ggv2id=b,h?(h=new h,h.open("GET",c),h.onload=function(){j();try{(d.execScript||function(a){d.eval.call(d,a)})(h.responseText)}catch(a){}},a=d.setTimeout(function(){h.abort()},3e3),void h.send()):i(c)}(); </script><script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script></div><script type="text/javascript"> WebFontConfig = { custom: { families: [ 'Font Awesome', 'Titling Gothic Narrow Light', 'Titling Gothic Cond Light', 'Titling Gothic Cond Standard', 'Titling Gothic Cond Regular', 'Titling Gothic Comp Medium' ], urls: ['//cdn.movieweb.com/assets/5a1da0b188178/sites/movieweb.com/fonts.min.css'] }, google: { families: ['Open Sans:300,300i,400,400i,600,600i,700,700i,800,800i', 'Titillium Web:400'] } }; (function() { var wf = document.createElement('script'); wf.src = ('https:' == document.location.protocol ? 'https' : 'http') + '://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js'; wf.type = 'text/javascript'; wf.async = 'true'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(wf, s); })(); </script><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:300,300i,400,400i,600,600i,700,700i,800,800i|Titillium+Web:400" data-norem></noscript><script> (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){ (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o), m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m) })(window,document,'script','//www.google-analytics.com/analytics.js','ga'); ga('create', 'UA-1660542-1', 'auto'); ga('set', {'dimension1':'Kevin Burwick'}); ga('set', {'contentGroup1':"Star Wars 8"}); ga('set', {'contentGroup2':"Star Wars"}); ga('set', {'contentGroup3':"Star Wars: The Last Jedi"}); ga('set', {'contentGroup4':"Movie News"}); ga('send', 'pageview'); </script><script> var _comscore = _comscore || []; _comscore.push({ c1: "2", c2: "17091571" }); (function() { var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true; s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js"; el.parentNode.insertBefore(s, el); })(); </script><noscript><img src="https://b.scorecardresearch.com/p?c1=2&c2=17091571&cv=2.0&cj=1" alt="MovieWeb" /></noscript><script src="//cdn.movieweb.com/assets/5a1da0b188178/sites/sites-main/js/jquery-3.2.0.min.js"></script><script src="//cdn.movieweb.com/assets/5a1da0b188178/sites/sites-main/js/jquery.waypoints.min.js"></script><script src="//cdn.movieweb.com/assets/5a1da0b188178/sites/sites-main/js/app.min.js"></script><script>docReady();</script><script type="text/javascript" src="//cdn.movieweb.com/assets/5a1da0b188178/vendor/youtube-playlist-player/js/yt.min.js"></script><script type="text/javascript"> Q.youtube_playlister('movieweb'); </script><noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=4fQco1IWNa10zK" style="display:none" height="1" width="1" alt="alexa" /></noscript><script type="text/javascript"> var w_yahoo = (top == self) ? window : window.top, d_yahoo = w_yahoo.document; w_yahoo.adUnitCode = w_yahoo.adUnitCode || []; w_yahoo.adUnitCode.push("6642de07-01b7-4efb-8616-3b3ef713d44e"); w_yahoo.apiKey = "XD9B6HTTT8X4YJYSV7D7"; (function(){ var script = d_yahoo.createElement("script"); script.async = true; script.src = "https://s.yimg.com/av/yap/ga/yap.js"; d_yahoo.body.appendChild(script); })(); </script></body></html>